Info to enable localization is unnecessary when have mock gps BT working

ulmus shared this idea 5 years ago
Completed

have turned off gps and wifi localization but I have working Bluetooth connection. Locus has gps icon in green and position is from mock gps with 3rd party BT provider. So... is it necessary to show remainder to turn on localization if locus has position already working?

It is a little annoying when everytime I have to see that at startup of locus. I have turned off wifi and gps localization as default and don't want to turn it on to not to see that remainder.

Please, if locus has gps position provider, don't show that window if I have turned off internal gps and wifi positioning.

Comments (5)

photo
1

hello ulmus,


it's not so simple as it looks. Anyway I did one small improvement in current Locus code that handle GPS location, so hope it will help in this case, to not to show such notification. Let me know if it will work as expected in next version.

photo
1

If you mean 3.2.3.10 then it does not work.

photo
1

Hmm, so another try in next 3.4.0 version if this do not help.

photo
1

After your comment I did play again with it. And it seems to behave a little random. I have set option to remember gps state on or off and sometimes I start locus and gps is off but I was closing locus with gps 'on' in locus.

Sometimes locus start without that popup sometimes with.

I think that it may be some timing issue, some responses are late or something...don't know... but it looks like that because its random.

P. S. Option to keep previous gps state is not working? It turns off gps sometimes.

Comment is for last stable pro version. But beta seems to look the same.

photo
1

There should be a problem, that you started Locus too soon after exit. There are some services and save state and finish itself during next five seconds after you confirm exit.


So I recommend for this testing, wait always at least five seconds, till you start Locus again. Same with current problem.


Anyway as I wrote, please check next Locus Pro or testing version. Current solution should help.