This object is in archive! 

Irrational car journey leg speeds

Bob Hawkins shared this problem 5 years ago
Not a Problem

Something occurred on my most recent long motorway journey that I have not encountered previously: I have the track recording panel visible whenever I travel by car. I have found it to be very reliable until my most recent journey. I use cruise control as much as possible, which my first example file, Journey legs 1, demonstrates. I saw at one point, however, the maximum speed displayed was 80+mph. I see, upon investigation, 300 instances of legs up to 108mph and erratic changes of speed as in Journey legs 2. My similar journey of 7374 legs a few days earlier in the reverse direction shows a total of three irrational legs: one at 86mph and two at 104mph - that is all. It is difficult for me to understand that gps vagaries can apply so differently on two similar journeys. I wonder if something else might be the cause?

Replies (6)

photo
1

Hi Bob,


Locus gets all values of coordinates, elevation or speed from your device sensors - GPS. So if there are such deviations, the problem might be in it. What Android OS do you use? Have you tested the track recording as well? Is the recorded track twisted or contain few trackpoints? If yes, try installing GPS locker: http://docs.locusmap.eu/doku.php?id=manual:faq:gps_lost_fix_android6#gps_locker.


regards


Michal Stupka

photo
1

Michal

I thank you for taking the trouble to reply to my post. I quoted two similar journeys. Each provides similar results: outward - 279 miles/7374 points/200 ft average distance between points; return - 277 miles/7564 points/193 feet average distance between points, One track lies perfectly over the other and the motorways they follow. My Moto G 4G has Android version 4.4.4 installed. There is no change since my purchase two years ago; all of which makes what happened on that journey most difficult to understand. I had a further such incident on a short journey today. I fear the first observation will not be an exception. I do appreciate, however, this is not a LocusMap issue, probably - I am clutching at straws for an answer.

photo
1

Hi Bob,


do you measure the speed by some external sensor or just by your mobile? Will you please share the GPXs of your tracks here for analysis?


Michal

photo
1

Michal

I drive using my mobile 'phone alone with LocusMap, connected via USB to the car's cigarette lighter so that the 'phone is on, charging and viewable the whole journey.

I attach .gpx files of the outward and return journeys in question.

I thank you for your continued interest.

photo
1

Good day Michal,

thank you for your shared exported files.


I see here two questions (problems):

1) what about speed values in Locus Map itself? Are they correct there?

2) why are you using Locus Map from September 2016 and not the latest version? Track exported with latest version should be correct. Better ... it is correct even now, but exported data contains only seconds. Because you record points really often, time round on seconds cause these problems in speed. Latest Locus Map version export time with milliseconds, so speed values should be correct.

photo
1

No reaction here for a month so I'm closing this topic.

Replies have been locked on this page!