kml/kmz with no importable content (points/tracks) aren't shown in the list of Active items

aaaa shared this problem 3 years ago
Not a Problem
  1. Open the attached file in locus.
  2. Locus will say that there is nothing to import and ask you if you want to display content on map. Click yes.
    45f6eff97c312509e76dd0c0d6be8ba3
  3. Click this button:
    2bd6baa6d48efd52f59d99e78e025467
  4. Click Active items

  5. The Kmz file won't be shown.
    b0dba9ef48660dec69fd6253ec094cae


When there are points/tracks in the kmz file, it's normally shown in the list.

Comments (5)

photo
1

Hi,

don´t import this file.

Copy it to

locus/mapIthems

if it´s activated, it is visible inside "active items" for me


Wolfgang

photo
1

I know, but still it's a bug.

photo
1

Hello,

in this case, I cannot say it is a bug. Even in "Active items" menu it is clearly visible "Enable some from your MAP ITEMS first". Enabling items over "map items" screen is a lot more complex then just this "import" tool, that's why it's separated.


So if same problem does not happen in case of loading over "map items", then all is fine.

photo
1

But if you open this file, it's shown in the list. It's the same file with one point added. If is not a bug, then it's at least inconsistent behavior.

46cc8905579399bab4a68f5d2bd510ccc62c4b708d9225460208190136276593b51fa9d237fc103813d09ea045f94872

photo
1

Hi,

agree, "inconsistency" it is. Quite complicated to solve for now. Thanks, I'll keep this in my mind.