This object is in archive! 

Languages in Route Planer

Slavc shared this problem 17 months ago
Solved

Heloo!


I am from slovenia and I use the Slovenian language.

I have a translation issue in the Route planner menu.

When I click on a point in the route and then press the arrow icon (photo: Route Planer Points), an incorrect translation is displayed. Not Slovenian. I think it's Slovak (photo: Route Planer)

I hope this can be fixed.

Thank you and best regards.

Comments (6)

photo
1

Good day Slavc,

these texts are most probably generated from the defined text-to-speech language. May you please check what is your settings in settings > language > text to speech?

Also just for sure: did you use custom TTS messages? It is not well-known method of Locus Map, so if not, it is ok.

Thanks.

photo
1

Heloo,

The first thing I had in the "text to speech" language was Czech, and in the text of the points names in the Czech language. Then I put it in English and got points descriptions for the names of the English icons.

In the settings> language> text to speech menu there is no Slovenian language. V In the navigation menu, I do not have the selected TTS system. I have the Slovenian voice Tanja in the menu: Locus / data / nav_audio /.

Voice navigation works fine. I only have the problem with the text in the descriptions of navigation points, which is now in English. I would like a translation in the Slovenian language, if at all possible.

I attach pictures for information.


Have a nice day and thank you.

photo
1

Good day Slavc,

oki, understand, thanks. These texts should really be generated in the language selected for TTS, but even on my device, I do not see Slovenian between TTS options, interesting.

So I've improved this to be it more logical. So in the next version (you may try it in the next Beta version as well), these names will be selected based on the language used in the application.

Let me know after you test it, if it works correctly.

Menion

photo
1

Hello,


Thanks for the quick reply. I do not think there is a problem in the TTS file, but in its connection with something. I manually translated the file "en_sample_v4.tts" into Slovene, but it did not matter in navigation.


I'm glad you understand what the problem is and that ro is solvable. I'll see how it will work in the new version of Locus and let me know how it works.


thanks for the help

Slavc

photo
1

Problem with the naming of navigation points should really be solved in next version. Names will come from internal app translation, not from TTS system. Anyway, I still think there is some problem with TTS. Main problem is that you do not see Slovenian language in TTS selection. You may check settings of text-to-speech directly in system settings, somewhere under language & accessibility.

To make your custom translation work, it is necessary to use Slovenian TTS and also rename your file to sl.tts in Locus/data/tts directory. Then it should work.

photo
1

Hello,


In the settings> Language and units> text to speech there is no Slovene language, but there are several others. As I set up English, it appears in the Locus menu> data> TTS "en.tts". Even if it is deleted and copied "sl.tts" it does not work, but the text is still in English.


We will need to wait for a new update and then we will see.


A beautiful day,

Slavc

Replies have been locked on this page!