Live Tracking - entering a private room not working

shushuk shared this problem 4 years ago
Solved

Hi,

I purchased a Premium subscription to create private rooms for buddy tracking. Unfortunately entering the password-protected room does not work.


Smartphone 1: Locus Pro (latest version), Premium Subscription; I created a private room and generated the key.


Smartphone 2: Locus Free (new iinstallation), no subscription; On this smartphone I try to enter the private room (manually, not via any links). After entering the key Locus tells me that the process was successfull. But I still only see the public room.


With running GPS and live tracking (all green) on both smartphones I don't see the position of the partner.


Am I doing something wrong or is this a bug?

Bought a year-subscription.....


Thanks for any help

shushuk

Replies (3)

photo
1

Addition to above problem:

Today I planned to try something different. But when entering the live-tracking dialog I noticed a foreign (!) private room of which I was a member. Never created or entered a room named "Chris". And this room had the same(!!!) key as the room created by me yesterday.....?!? Not very private in my opinion ;-)


Is this feature still in beta? Is it trustworthy? Anyone else with similar problems?

Regards, shushuk

photo
1

Good day shushuk,


I'm really surprised that something like this happen. You use email hapl****@gmail.com , is it correct?


We will check tomorrow where may be an issue and let You immediately know. Feature is not in "beta", we consider this as fully stable and working. This is anyway big issue we invest. Thank you for a bug-report!


Jiří M. aka Menion

photo
1

Thanx for response,

No, this is not my email.

Smartphone1 (creation of the room) uses w.sc******@gmail.com, Smartphone2 uses d.sc******.......

Hope that helps,

Cheers, shushuk

photo
photo
1

Good day,


unfortunately we have some serious problems with finding possible source of troubles. In our logs on server and even during some testing, we are not able to simulate this issue. So I need to ask few additional questions:


You wrote "I noticed a foreign (!) private room of which I was a member. Never

created or entered a room named "Chris". And this room had the same(!!!)

key as the room created by me yesterday". How you know that this room had same key when as a quest in room (not a room owner) you cannot see room key.


May you please try to simulate this issue once more and exact! steps, that simulate this problem, write us here? There is not many options what you may do differently compare to my own testing, but I needs to be sure. In case, issue happen again (so you won't see new added room on second account), stop doing any more steps, so we may see this "failure" state on our server.


Thank you very much for a help and sorry for a complications!

photo
1

Hi Menion,

Regarding to your question about the foreign room "Chris": obviousely I was not only member of this room but also admin. It had the same appearence as if I had created the room. Therefore I also could share the key and compared it to the one I sent the day before to smartphone 2. I also made a screenshot of this but that would not help much as it only shows the selected but unknown room.


I then tried to reproduce the problem and start from 'zero'. Therefore I tried to delete another private room created for testing purposes with a friend. But I can't delete this room (named "Alex") any more. I get an unknown error with code 5423 (screenshot available).


However, next steps are to reproduce the problem:

- Create new private room on Smartphone 1via "+ add own romm" (in german "eigenen Raum hinzufügen")

- Name of the room is "Testraum". No description, default symbol

-??? The undeleteable room Alex no is replaced by Testraum??? !

- show key for room Testraum: 1QRD-A6**

- on Smartphone 2 start buddy tracking dialog

- Edit locus live tracking

-Try to add password protected room (in german " einen passwortgeschützten Raum hinzufügen ")

- Enter the key and confirm

-"Prozess erfolgreich" ---> successfull

- When message disappears there is no new room in the list. Only room available is "public room"


I stop here. As I don't have gps Signal right now I can't check whether I can see the position of each other. But actually it can't work as Smartphone 2 is no member of the room yet...


Next thing I would try to do is to delete the newly created room Testraum and check if it shows the same behaviour as room Alex. But as you requested I don't continue.


I hope that helps. Feel free to ask any further questions. Thanx for your support and for your very (very!) valuable app!

photo
1

Good day,

thank you very much for a very precise description. We were able to identify source of troubles on our server. Issue should be now fixed and whole system working as expected.


Please try it and let us know in case, there will be any remaining troubles.


Thank you!

photo
1

Thank you very much, service is running as expected :-)

Perfect!

photo
Leave a Comment
 
Attach a file