Locus freezes for 20 sec or more after activation of map rotation

Tirfo shared this problem 5 years ago
Closed

Hi, I'm encountering a problem whenever I activate map rotation while I am moving:

A) Start locus while I am moving (eg if I want to have quick look at the map, phone mounted on my bike) and have “hold map center” and “rotate map” activated > locus searches for a GPS signal and after (!) the GPS fix it freezes for 20 sec or more. Before GPS fix, map rotates and no freeze.

B) While locus is running, GPS on and fixed: switch on map rotation > freezes

My settings are: Hardware compass, auto change on; 4 km/h, light filter; vector map; MotoG XT1039

Any idea? Thanks for help!

Replies (7)

photo
1

same with hardware compass off?

photo
1

Hello Tirfo,


sorry for a complications. Gynta's question is absolutely correct. It may help to identify, if problem is because of rotation of map or because of some feature that is connected to GPS receiver.


Also you wrote .. "freeze". Did you tried to leave Locus little bit longer even if Android display an error dialog?


Last thing ... are you using latest Locus version 3.17.2?

photo
1

Sorry, it took me some time to try a few variants:

1. Use HW compass: off, rotation: on > freeze

2. HW compass on, threshold15 kmh: freeze if I am going 20 kmh; if I go slow, sometimes no freeze (in this case rotation is triggered by HW compass)

3. HW off, rotation off: > freeze sometimes


To me it looks like freeze occurs between first GPS fix and the time when GPS direction and speed can be calculated correctly.

If this is true then it could help if Locus waits until GPS based direction can be determined correctly from the signals and then switch from HW compasse to GPS direction.


Usually after 20 sec or so Locus shows direction and map rotation correctly. There is no error warning.


Thank you!

photo
1

Locus 3.17.2. The problem, however, has been there since a few months actually.

photo
1

Hello,


so this "freeze" means that Locus "freeze" for a 20 seconds and then it runs without a problems? Am I understand correctly?


In this case, may you try to create a log right after Locus starts working again? How to do it: http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log , and I'll hope that in log will be something useful. Thank you

photo
1

Hi, whenever I tried to reproduce the problem, it didn't occur. When I wasn't prepared to record a log, of course it was there again. ;) Sorry, I will give up for a while. It seems, however, that it somehow is connected with the quality of the GPS sigal. Locus seems to wait until the GPS signal is good enough to calculate the orientation, which may take some time so the screen looks like it freezes. On the other hand, Locus switches from hardware compass to GPS orientation when the GPS-calculated speed is above the threshold for switching. Sorry, I don't have an idea how Locus handles GPS signals, but could it be that GPS position and speed are calculated before the orientation can be calculated and thus there is a lag between both events? Thanks!

photo
1

Good day Tirfo,

"whenever I tried to reproduce the problem, it didn't occur" > don't even talk me about this :).


Anyway to your problem. Please try me explain what means your word "freeze". Locus is stuck and it completely do not react, or you mean that screen just do not rotate?


If problem is just that screen do not rotate, then it looks like your device needs some more time before it computes direction of your movement. I'll try to next version, enable using directly computed direction of movement in case, GPS location from your device do not have this value already computed (which is probably your case). So please try next version and let me know after few tests (if you will still have patience on this).

Leave a Comment
 
Attach a file