Locus locks my screen

Jan Richter shared this question 8 months ago
Answered

I used a HTC U11 life and now a Samsung Galaxy A5, both with Android 8.0.

On both Locus locks my screen 2 minutes.


I disabled all screen locks - in global settings and in my presets. In Android settings I set automatically locking to 10 minutes.


Locus should not lock my screen when I disabled it. Is there any additional setting or should this be fixed?


And: when Locus locks my screen I need to use my PIN code. The fingerprint authentication is not working in this case.

Comments (20)

photo
1

The one in global settings AND the one in my preset. And a third one you can see in screenshots.

photo
photo
1

Hi,

I'm not sure how it is in Samsung devices but in some others there is an additional system permission for apps to be on "lockscreen" - without this permission disabling screenlock in Locus doesn't work.

photo
1

I don't understand why Locus should be "on lockscreen". The screen should not be locked at all.

On my HTC U11 life with Android One I had the same behavior.

And if there is absolutely no other solution, a compromise could be unlocking with fingerprint. Typing the PIN code on a bike ist more than difficult.

photo
1

The screen got locked by android, you can't prevent this.


But if locus has enoght permission it could unlock it.

Without this permission disabling screenlock in Locus doesn't work.


Have a look at your locus app permissions and restart locus if you did change any permission. Tell us if you meet all preconditions for preventing lock screen and still have this issue.

photo
1

Mám podobný problém s Samsung A3. Myslím, že to souvisí s skrývá horní panel. Aby tento problém dojít, musí být GPS zapnutý. Zobrazí-li se horní panel, je vše v pořádku. Pokud je skryta a stáhnout dolů oznamovací panel, bude zámek obrazovky. Po stisknutí tlačítka napájení Vidím to, ale otisk ne, systém mě vždy vyžaduje nakreslit postavu. Oznámení nemohou být zobrazeny se skrytým horním panelu. V Locus Nastavil jsem „odemknout všechny obrazovky zámky“. Problém je stejný jako v PRO a BETA verze.

CZ: Velmi podobný problém mám i u Samsung A3. Myslím, že to má souvislost se skrýváním horního panelu. Aby se problém projevil, musí být zapnuta GPS. Pokud je horní panel zobrazený, je vše v pořádku. Pokud je skrytý a stáhnu dolů notifikační lištu tak se zamkne obrazovka. Stiskem zapínacího tlačítka ji mohu zobrazit, ale otiskem prstu ne, to po mě systém vždy požaduje nakreslit znak. Notifikace tudíž se skrytým horním panelem nejdou nijak zobrazit. V Locusu mám nastaveno "odemknout všechny zámky obrazovky". Problém je stejná jak ve verzi PRO tak i BETA.

photo
1

@Jan: I just mentioned that in some devices like e.g. Xiaomi Locus needs permission to "be on lockscreen" so that disabling screen lock could work. Why is it necessary, I don't know. I'm forwarding this topic to the main developer so that he can share his opinion.

photo
1

@Falco:I don't think that screen is locked by Android. In Android I set the auto screen lock to 10 minutes after display standby.

@Michal: Thank you!

photo
photo
1

Some more information: sometimes directly after opening Locus (when it was closed), it locks my screen too. Not only after the 2 minutes.

photo
1

Good day Jan, others,

let's solve this issue.

Firstly I need some more information.

  • You wrote, "In Android settings, I set automatically locking to 10 minutes". By this, you mean "Screen timeout" system settings = time when screen turns off?
  • Also your "Lock the screen" > this means that simply device turn screen off and after you turn it on, the screen is locked by your secured unlock mechanism (PIN, fingerprint, ...)?

Locus definitely does not turn off the screen without any reason. Reasons for this are defined in Locus Map Settings > Display > Screen on/off control. So check these settings please and rather turn it off completely.Usually, best is if I'll be able to simulate your problem on own Samsung device, so please write me your settings in the device that affect this (setup of screen lock, mentioned time when screen turn off), so I can setup it as well.

Thanks,

Jiří M. aka Menion

photo
1

I now disabled "Always screen on" and there are no more unexpected screen locks.

I don't know what it has to do with that but this os the solution for me.

photo
1

http://help.locusmap.eu/topic/locus-locks-my-screen#comment-57488

Your screenshot 3 : Always screen on: Not enabled. ?

photo
1

The screen should not be on all the time. It should not be LOCKED.

photo
1

Good day Jan,

thanks for additional information. I'm worried that task is currently unsolvable. Work with secured lock screens (pin, fingerprint, ...) is not basically supported and if any app bypass it, it is most probably thanks to some "hacks". So simply, Disable screen locks > Basic screen locks cannot work for you because you use secured lock screen. Using of "All screen locks" is on own risk and it's known to me that on some devices it gives unwanted results. And this is most probably your case.


Why disabled "Always screen on" helped here, I have absolutely no idea. But, I'm glad you found out a working solution, perfect!

photo
1

I have the same problem with Locus Pro on my Samsung S5 with LineageOS 15.1. In Android settings I set automatically locking to 30 minutes. When Locus Navigation starts I get the navigation info/map shown on my screen for 10 seconds. So far, so good. But the screen is also immediately locked after first navigation information. If I want to leave the navigation screen by pressing the home button I have to enter the PIN. The sreen is looked by administrator. I have disabled "Always screen on", but this doesn't fix the problem.

Any idea?

photo
1

Good day Joerg,

what means "automatically locking to 30 minutes"?

If you let Locus to turn the screen off, then it will be locked in case you use "secured lock screen". This is something I'm unable to "hack", it is how system works.

photo
photo
1

Hello Menion,

I have set Android to look my Screenshot after 30 minutes of inactivity. Lotus "overwrites" this settings, so I have to enter my pin immediately after the first navigation Instruktion.

photo
1

Do you have enabled Screen on/off settings to turn off automatically? Locus Map does not overwrite any system settings. Anyway if you have set automatic screen off in Locus, then it logically turns off the screen when needed and you have to pass over your security to turn the screen back on.

photo
1

Menion,

that was the crucial clue. In fact, it seems to be due to the automatic shutdown! I'm pretty sure that Android behaved differently before updating to LineageOs 15.1, but in any case, everything is going fine now. I would never have come to the automatic shutdown. Thank you for your great support!

Thanks,

Joerg

photo
1

Perfect!

It is possible that some previous version of your Android ROM, "Disable secured lock screen" option in app worked. Anyway as I wrote here, this third option (disabling SECURED lock screen) is not reliable and works unfortunately on every Android little bit different :/.

photo