This object is in archive! 

Locus Map Pro doesn't show request to enable GPS at start

Dmitry Lesev shared this problem 16 months ago
Solved

Hi

After today's update i can't see anymore this request (after initialization stage) in case if phone's GPS is switched off

Comments (6)

photo
1

Good day Dmitry,

thank you for your bug report. Issue found and will be fixed in the next 3.37.1 version.

Menion

photo
1

Unable to use Locus with GPS disabled. Every 5 seconds the GPS config menue pops up. Hope its the same bug and fixe you mentioned.

photo
1

Hmm this really happen? Interesting. Version 3.37.1 is already out so please try it and let me know, thanks!

photo
1

Oh, I just installed 3.37.1. Did not noticed I alredy got the fix.


It' s weird.

I started Locus after update with GPS disabled. Every 5 seconds (or less) I got the Android GPS config screen. Not the notice you get when GPS is disabled at bottom of screen.

Closing the Android config menu tock me back to Locus, after 5 seconds ... you get it ;)

Closed Locus, enabled GPS.

Started Locus again, no error, GPS was enabled. So I disbled GPS again and closed Locus.

After that, I can start Locus without any issue. The banner at the bottem "no GPS bla bla bla" appears and disappers.

All fine now.


btw, the last GPS fix is gone after update. If I push the "centers" button (bottom panel left), I'l go to Prague.

Nice city, but not the expected ;)

photo
1

Hmm oki, but now it seems to work correctly right? Fine and sorry for this "mess".

And yes, in latest version was change in GPS handling (added filter for more fluent movement) and last stored GPS location was reset. So it may take a moment till Locus gets new "your current" location. Hope these are last troubles you meet in new version :)

Menion

photo
1

They aren't troubles if there is a solution. Even if sometime it takes days to fix it.

Locus is great. I moved over from Ozi 6 or 7 years ago. Helpfull tools made it easy to take all the maps with me.


Thank you for your support

Replies have been locked on this page!