Locus 'offline' maps list does not display.

Adam shared this problem 3 years ago

Hello, I have NEXUS 7, Android version 5.1.1, Locus Pro 3.11.3, working dircectory is: / storage/emulated/0/Locus.

My device does not have SD disc.

Everything has been working fine until recently. I experience this problem:

- run Locus

- enter Main Menu > Maps > got to tab 'Offline' => Locus says 'loading' and nothing will ever happen anymore.

Application does not crash but the list will never appear, even if you wait several hours. My maps are in 'maps' folder in .sqlitedb file format and all worked correctly in the past.

Meanwhile, the list on 'Online' and 'WMS' tabs works fine.

You can switch between the tabs but 'Offline' tab still says ' loading'.

To retrieve the list you need to go to sub-menu options and chose 'Smart Choice' or 'All Maps' depending which one is in use by default, this refreshes the screen, the list appears then. You can also use 'Refresh' function on menu at the right upper corner but then a message 'Working' appears and application freezes. I run it again and again and the same happens all the time.

The second issue, probably has got something in common with the above problem. Namely, you go to:

Main Menu > Maps > 'Offline' > (the list will not appear so you use sub-menu option) 'Smart Choice' or 'All Maps'

> push '+' button > 'Add external maps' and at this point application says 'Locus Pro isn't responding'. All other options i.e. adding or downloading works fine but 'Add external maps' freezes the Locus.

I use X-plore file explorer for Android and maybe some time ago I unintentionally moved some folder in Locus directory? But seems that all maps folders and files are in their right place.

Thanks for any help.


Comments (4)


Good day Adam,

sorry for a late response. Let's try to solve this issue. From what you wrote, it looks for me like some problem with SD card, but because you do not have a card, we have to search for different reason.

May you please try to install latest Beta version of Locus .

If same problem happen again (first or second) with this version, immediately after problem appear, create for me a log by this method:

Thank you for a help and sorry for a troubles.


Hello, thank you. I installed BETA as instructed. All tested and everything works fine.

Now on, I have a LOCUS Free Beta - on start it says: "works as Locus Map Pro". My first Locus Pro is left and installed as before.

Can I now unistall old Locus Pro and change somehow 'Locus Free Beta' into 'Locus Pro' in the future?


Hello, I'm surprised to read this. Expected similar problems. Hmm anyway please no, keep Locus Map Pro. Once time will run out, Beta version became basic Locus Map Free. You may keep it for now if you wants, but after Locus Map Pro will be published (next week), there will be no usage for this Beta so you may remove it.

Anyway I'm glad that changes I made in map manager solved your problems. To be true, I still think, there have to be some different problem, so if any issue happen again, you now know, what to do - log + precise description of problem usually helps!


Okay, thanks great.