Locus Pro 3.21.1 locking-up on Android 4.2.2

Nick Fane shared this problem 2 years ago
Closed

For a while now I have been having big problems with Locus 3.21.1 on my Android 4.2.2 tablet. It seems OK until I use it in anger - with GPS on and tracking, then it keeps freezing or will not function when the tablet returns from 'sleep'.

The map does not load properly and usually nothing will function or move at all - the interface is simply stuck.

I have completely reset my tablet to factory settings - but to no avail, the problem persists, even with very few applications even loaded on the tablet (a Prestigio Multipad 4 Ultra Quad)

I have noticed that if I get a 'Locus has stopped working' and then 'report a problem, once sent it often works again - for a few minutes. I have recently sent some 'reports'.

Comments (9)

photo
1

Good day Nick,

I'm really sorry to hear about these troubles!


I was able to find out your reported logs in Google Play console. Seems to be quite rare issue when app tries to display some content on the screen, but screen is not yet ready to do it (like as you wrote, to display something when app is sleeping).


Unfortunately these Google Play logs (when you tap 'report a problem') are very short and not always perfectly usable.


May I ask you for additional help? Here is described method how to create more complete log , so please try to create it right after crash, thank you! I hope you will be able to simulate this problem easily even at home.


Thank you!

photo
1

Thank you for the prompt help.

Finding Developer Options was a bit of a challenge, but 6 clicks on 'Build' did the trick.

I have just been for a short walk locally with Track Record running, and soon had the same lock up problem.

I hope the attached file is what you need.

Kind regards, Nick

--

Nick

From: Locus Map

Sent: 20 February 2017 06:45:01 GMT

To: Nick Fane

Subject: New Comment in "Locus Pro 3.21.1 locking-up on Android 4.2.2"

photo
1

Good day Nick,


firstly thanks for a log.

Unfortunately I'm really sorry, but I have no option I know about, how to help here. We are suffering because of this problems for many months already and almost everytime was some problem in some device settings or any other application that was killing Locus Map.

In log is no information about crash of Locus ( maybe log was created too later after Locus Map was terminated ), so I have no idea why this happen.

Only what I can do for you, is offer you refund of app ( if you purchased it sooner then year ago ) or any older version of Locus Map ( if you that that version x.x worked fine for you ). Sorry I have no better news. Please let me know. Thank you for understanding.

photo
1

Hi Menion

This is sad news. The cost is not an issue - and I purchased more than 1 year ago.

Do you mean that you have had a lot of similar reports and are unable to fix many of them?

My tablet was recently reset to factory conditions, and it has few apps re-loaded and nothing much else was running (probably BT WiFi and K9-mail in the background only)

I did dump the crash log immediately after attempting to recall the tablet from sleep and finding Locus 'stuck'.

The problem is definitely associated with being in GPS track - it does NOT happen if I am just browsing the map.

However, if there is anything else I can do to help isolate the problem, I am very willing to try and help.

I think the problem started sometime in the late summer last year. If that enables you to provide me with an old version - from say early 2016 - that would be a good temporary solution. (I don't know exactly which last version was OK)

Unfortunately it makes 'updates' painfull because there is no choice between 'update all' and 'choose each separate update one at a time' - which is tedious to say the least. (Unless you know better on that?)

I look forward to your further help/comment.

Regards, Nick

photo
1

Good day Nick,

sorry for a delay in response.

Yes, I wanted to say that similar (not exactly same) problem was already reported few times, but in all cases as I remember, it was an issue in some battery optimization of Android itself ( like we wrote about it here ) or any aggressive battery optimization application that was closing Locus Map on background.

Anyway I'm checking your log once more. Seems that problem why I doesn't see anything useful there, is because your device seems to be very "talkative" and in 3.000 lines of log is only last 18 seconds. This is a problem of this system.

Do you have your device rooted?

------

Oki, if you really wants to invest a little time on this problem, I've found one alternative solution how to get logs from your device. I've found it on XDA server here: https://forum.xda-developers.com/showthread.php?p=48915118 .


  1. install small ADB installation from mentioned page or from this link: https://nas.asamm.com/share.cgi?ssid=0dQHAxF
  2. you also need to put your device to developer mode and enable USB debugging ( which you already did in previously )
  3. open command line in your PC ( on windows for example WIN+R, "cmd" > Enter )
  4. insert text "adb logcat > textfile.txt" and Enter
  5. now you needs to get mentioned crash on your device, but it needs to remain connected to your PC. Hope this won't be a problem

You are first to who I wrote these steps, so I hope it will work without a troubles. Thank you.

photo
1

Hi

I have yet to ‘digest’ this reply thoroughly – but for the moment it is all on hold for me.

The device is NOT rooted.

Yesterday, when I was trying to get a better crash report, Locus locked-up completely and the tablet would do nothing.

I had to hold the power button to ‘kill’ the tablet – and that is exactly what it did – the tablet will no longer start or charge – it seems completely dead. An unfortunate coincidence?

I’m not sure where next – probably open it up it up and disconnect the battery?

Or maybe buy a new tablet!

I will update again when I know more and have thought about your reply.

Regards,

Nick

nick@fanes.uk

From: Locus Map [mailto:locus.map@asamm.com]

Sent: 23 February 2017 10:15

To: Nick Fane

Subject: New Comment in "Locus Pro 3.21.1 locking-up on Android 4.2.2"

photo
1

Hello,

complete lock of device is really unfortunate. Anyway to Locus defense I had to say, that every app should run in something called "sandbox" ... separated process that should not affect whole system. If this happen, then it looks more like some problem in device.


Here is also APK file of Locus Map Pro 3.15.3 from February 2016: https://nas.asamm.com:443/share.cgi?ssid=0dIrsgf

photo
1

It seems that my tablet is terminal - absolutely nothing I have tried revives it, it simply will no longer do anything at all.

So, there is nothing more I can do to isolate the problem.

I am just left with a slight mystery as to why it died permanently when killing it with Locus jammed - and needing a new tablet!

You may as well close this thread.

Thank you.

photo
1

Hello Nick,

sorry to hear it ... quite complicated task. What about an year old version? Same issue?


Not sure how may I help here more, sorry.