Loosing satelites when recording track

Djordje Mikic shared this question 2 years ago


About since the upgrade in May I have following problem:

I start recording and switch off the phone. Some time afterwards a sound is signalizing that the GPS signal was lost (about 5 min, not always same time).

I switch on the phone and see there are not available satellites - but I get not position again until I tap to "turn GPS off" and then tap to "turn GPS on" !!

When not recording it is normal that after switching off he losses the signal but after switching on it founds them again - it is working correctly.

When recording and keeping the phone on - it does not looses the signal.

Weird is that when recording

1- the program loose the signal after some time (should not, settings checked !!!)

2 -after switching the phone on it still doesn't find any until I switch GPS off and then on.

Previously (about month and half) it worked flawless.

Please note that I have checked the settings. For testing I installed some GPS tracking apps and they work so it seems that the phone and GPS is working well.

I need a help!

Comments (2)


Good day Mr. Mikic,

please check our manual page focused on this problematic: http://docs.locusmap.eu/doku.php?id=manual:faq:gps_lost_fix_android6 . This should help on similar problems in most cases.

Also please check that you have disabled "Auto GPS-off" feature in Locus (Settings > GPS), as it may affect connection to satellites as well.

Let me know if problem will be solved, thank you.



Thank you very much for the help.

The problem was in "energy saving" section of the setup. Android was switching off the GPS. I have excluded power saving for Locus and since that it is working fine.