This object is in archive! 

Maps overlay problems

Tomas Vanco shared this problem 20 months ago
Not a Problem

Hi,

few weeks ago started trouble with overlaying offline map (both are offline). I use overlay with ~30% transparency. But when I'm zooming, or moving the base map, the overlay is rendering with 0% transparency.

I thing, it didn't being wrong from new rendering engine, but much later. From some updates.

If it's needed I can make some testing or give you more detail description of trouble and device parameters.

Replies (5)

photo
1

Dear Tomas,

I'm sorry for the troubles. However would be possible for you to create a short video documenting this issue - if you don't know the right app, I would suggest AZ Screen Recorder for screen recording: https://play.google.com/store/apps/details?id=com.hecorat.screenrecorder.free

Thanks, Petr

photo
1

Hi Peter,

I think I found out the cause. I have had set up another map to overlay that was displayed.

Explanation. I have 2 maps that I use to overlay as I needed.

1st - forest rotes

2nd - avalanche tracks (in mountains)


I have chosen 2nd, but at home where this map have not covered area, Locus is rendering 1st map.

I don't know, may be it is cached or what. But it looks like unwanted feature.

Is it describe understandable? :)

photo
1

Locus renders at least one map if another one doesn't have coverage (at home). I think that's correct behaviour. Or what's wrong? :)

photo
1

I didn't know that this behavior work for overlying map too.

In this case. Would be right, change overlaying map in overlay setting to be corresponding for what Locus is rendering.

Or at latest, use the set transparency from this settings.

photo
1

Do you mean that Locus should cut the base or overlay map because the maps have different coverage?

photo
1

I don't understand what you mean.

I don't have any problem with base map.


I record a video for better explaining.

https://youtu.be/-tODSKuq2Ho

Es you can see, when I change overly map, it still render the forest's routes. But, when I'm zooming the transparency is being making trouble. When I'm moving base map, you can see the difference of saturation on purple routes.

photo
1

Thank you for the video. I can finally understand your situation. Is caused (very likely) due to enabled automatic map loading. Please change following settings: Menu > Settings > Maps > Offline maps > Raster maps - Automatic map loading > set No map auto-load

photo
1

OK. Thanks

Replies have been locked on this page!