This object is in archive! 

MapsForge offline maps no longer recognised

Peter Taylor shared this problem 5 years ago

I have some offline maps which I created myself from OpenStreetMap data in 2013 and 2015. I used osmosis to generate them in Mapsforge format, and they worked fine for years.

Recently, however, they do not appear in the list of offline maps. Unfortunately I don't know in which version of Locus Pro they stopped working. I tried to re-add one by copying it from the mapsVector directory to the root of my SD card and adding as an external map: I see it now when I open the "External maps" dialog, but it's not in the list of offline maps and refreshing the list does not help.

I don't see any indication in that the software has been updated to require a particular version of the Mapsforge format (and, to be honest, I'm not sure whether the format has versions, or what version my maps would be using).

Replies (2)


Good day Peter,

it is possible that you are victim of change we made in 3.28.0 version ( ) > "removed support for MapsForge V2 themes".

Even mapsForge maps has versions and currently latest map format is in version 4. Removed version 2 was really really old and by our internal stats, only less then 1% of users used them.

Sorry for an extra work, but please regenerate your map with new MapWriter or use any of many vector map sources like our own LoMaps in Locus Store, freely availabe OpenAndroMaps or any other.

If there will be something more I may help with, please let me know.

Ah btw. if it is really a problem, we may send you 3.27.x version, this is not a problem.



I've regenerated my maps with the latest version of Osmosis (0.46) and the MapsForge Map Writer plugin (20180124.072340-202) and it does indeed work. Thanks for confirming my guess as to what was going on.

Replies have been locked on this page!