Mapsforge V4 renders super slow - V3 works fine

Ákos Pap shared this problem 15 days ago
Solved

I've been using maps from openandromaps.org in Locus Pro for a long while, and they were always very good.

A while ago I tried downloading the V4 version, but it was super slow to render in Locus - when panning or zooming. So I went back to V3, which was fast.


Now I see that the last release of V3 is the September 2019 one, and there will be no more, basically forcing me over to V4.

So I tried it again, but it is still very slow, almost unusable to "look around" a trail.

I'm using the Elements theme (from openandromaps) for V4 and the internal "Hike & bike" for V3.


I'm using a quite decent phone (Google Pixel 1), so that shouldn't be a problem.


Any ideas?

Comments (5)

photo
1

which locus version are you using?Which Android version do you use?

photo
1

I added the Locus version in the dedicated field it shows on the right.

Locus: 3.40.1

Android 9

photo
1

Hello guys,

do not know why nobody complains about this "slowness" during Beta testing, but definitely you are not alone with latest 3.40.1 version. I've tried to find out more about this problem over the weekend and I think I made some progress. Today will be published a new version, so let me know if 3.40.2 will be better with this particular problem.

Menion

photo
1

In my related post, https://help.locusmap.eu/topic/new-ml-maps, I reported that 3.40.2 has fixed this slow issues.

photo
1

Seems faster to me, but I need to see it "in real life", that is, out hiking in the terrain. Will report back!