Marshmallow and track recording

Jürgen Holm shared this problem 3 years ago
Solved

Hi,


I'm now owning a S5 with latest Samsung's marshmallow since a few week. Locus works as expected, but track recording.

When I switch the display off, no data will be written. While the display is on the track will be recorded. Switching off all power save settings will not help. I moved the Locus directory to internal card - no way, track isn't recorded while display off.


So, i decided to install an GPS logger to see if there is a MM problem. GPS logger is writing data while display is off.


logical consequence: There is a problem with Locus, or I miss some Locus settings


Question: How can I activate some kind of logging to see whats going on while the display is off?

Comments (17)

photo
1

Good day Jurgen,

please check firstly this manual page, if you have correctly excluded Locus from doze/battery optimization mode ... http://docs.locusmap.eu/doku.php?id=manual:faq:gps_lost_fix_android6 , thank You.

photo
1

Hi Menion,


shure I did this. See attachment. I manually add locus to this list. Maildroid and Threema have done this

automatically by itself. Why did'nt do this locus?

photo
1

Hello,

you did this and it do not help?

Automatically ... I can't understand how any app may do this automatically ... for this is needed a special permission called "REQUEST_IGNORE_BATTERY_OPTIMIZATIONS" . When I've added this to Locus two months ago, few days later Google itself disable Locus on Google Play and I had to remove this permission again with new version.

photo
1

No, this did not helped.

And I swear, I did not add maildroid and threema manually to this list

photo
1

Hello,


sorry to say, but the newest version of locus did not fix my problem.

Today I've done a short walk, and recorded it. The GPX file contains 6 Points. 2 at start time an 4 at stop time whille the display was on. When the display was off, no points are recorded. But it seems to me, that 20 gps positions was seen by Android (see grep "SV Count" 2016-08-26-09-19-42.txt |wc)

I also saw many "E/LocSvc_ApiV02" errors of type QMI_LOC_EVENT_GNSS_SV_INFO_IND_V02 and QMI_LOC_EVENT_POSITION_REPORT_IND_V02.

Hope this info helps.

photo
1

Good day Jürgen,

thank you for your logs. To be true, I didn't expected that new version solve this issue. I was checking more info about new Doze mode, but this definitely is not the case.

I'm checking your logs. What you wrote is probably not important, anyway I've found something more interesting to me ...

  1. Line 7693: 08-26 09:19:20.021 D/LocationManagerService(1074): request f48c9e8 gps Request[ACCURACY_FINE gps requested=0 fastest=0] from menion.android.locus.pro(10395)
  2. Line 9326: 08-26 09:19:37.071 I/LocationManagerService(1074): remove f48c9e8 by menion.android.locus.pro

First line looks like Locus registered itself to be informed about GPS updates, but 17 seconds later Locus removed itself, which should happen only in case, Locus terminate internal "GPSConnection service". And this should definitely not happen when track recording is running.

If you are interested in fixing of this issue, I'll need some more help. I have currently no idea what this may happen, anyway I've prepared special version that print out to log all changes that is Locus doing around GPS. So try to run it and after same issue happen, create to me a log please, thanks.

Version: https://nas.asamm.com:443/share.cgi?ssid=0defHnK

photo
1

Hello Menion,


to hot to be outside!


Thank you for your test apk. After I installed you app (after removing/ renaming my Locus installation), track recording is working. So, I checked my settings. After playing a couple of hours around, _various/settings in my backup zip file is under suspicion. I cooked the problem down to two backup zip files: one file with a working track recording the other without.

photo
1

ps: the ..notok.zip leads to the same recording problem in my very old GT-S7580 running CM12.1

photo
1

Grrr Jurgen,

you have enabled "GPS auto-off" feature!! :)


Please check this manual if description will be logical to you. Problem here is your settings that define pause for 130s. This means that your should have just one recorded point per 130+ seconds, not more.


Try to disable it and let me know. Thanks

photo
1

Hello.

I am very sorry for the inconvenience and my misunderstanding , but i thought GPS auto-off means switch GPS off if no fix whitin 130 sec, or when the min accuracy is not achieved. Maybe the manual should read (avoiding the word "attempt"):

Switch GPS on only every specified seconds to reduce battery consumpttion

DE: GPS nur alle hier angegebene Sekunden einschalten um den Akku zu schonen.


Maybe it is worthy to think about a warning (+ reject starting?) in Locus if a user is trying to start a track recording with parameters which are senseless with these defined in GPS auto-off (when activated).


Sorry for the noise, jh

photo
1

Hello,

not a big problem so no need to sorry.

In your case, if I remember correctly 130s/50m/3600s, it means

- start searching for valid GPS location with accuracy better/equal to 50m

- search for max 3600s

- when such location is found, turn off GPS for 130s, then repeat


And warning ... I personally use sometimes this feature for full day recording when I need to save battery. If you set in recording profile required accuracy to 50 m as well, you will get quite nice recording with minimal battery consumption. Also "GPS icon" on map screen (if you have it in panel), have small "clock" symbol on it, to notify about enabled GPS auto-off feature.

Anyway I'll think about some kind of warning, thanks for an idea.

What about your problem, with better understanding of how this feature works, it recording working correctly for you now? Let me know if I can help somehow.

photo
1

Hello,


recording works like expected! I understand this GPS auto-off feature (now!) completely. May be one should consider a more detailed explanation of this feature in the docs or at least my suggested changes.

Thanks.

photo
1

Perfect, glad to hear it.


@Michal, please consider improving manual around "GPS auto off" feature as I described above. Or maybe a idea on a new blogpost > "Methods how to save battery with Locus Map" and prolink from manual to this post, thanks.

photo
photo
1

Hallo Jürgen


[DE]

Siehe http://docs.locusmap.eu/doku.php?id=de:manual:user_guide:settings:gps

Sollte in dieser Dokumentation etwas missverständlich formuliert worden sein, so bitte ich um Rückmeldung und Angabe der betroffenen Textpassage.

photo
1

Hi,


I suggest the following changes in http://docs.locusmap.eu/doku.php?id=de:manual:user_guide:settings:gps


EN:

Headline: Internal GPS auto-off -> Saving energy by internal GPS


To save energy, you can set a rhythm in which the GPS is turned on automatically. In order to achieve a significant saving effect, the interval between the switch-ons should be greater than 60 seconds.


* GPS update interval: GPS is only switched on at intervals of the seconds given

....


DE:

Überschrift: Internes GPS Auto-Aus -> Energiesparen internes GPS


Um Energie zu sparen, kann ein Rhythmus festgelegt werden, in dem das GPS automatisch eingeschaltet wird. Für einen merklichen Einspareffekt sollte das Interval zwischen den Einschaltvorgängen größer als 60 Sekunden sein.


* GPS Aktualisierungsintervall: GPS wird nur im Abstand der angegebenen Sekunden eingeschaltet

....


Within Locus settings I suggest: the headline should be changed according to the one above.


Sorry, for the delayed response.

photo
1

Hallo gynta,


nicht zufrieden mit der Umformulierung?

photo
1

Hallo Jürgen

Entschuldige. Dieser Problemreport wurde bereits als erledigt gekennzeichnet. Darum sehe ich eher selten genauer in solche Topics bzw. vergesse diese sofort wieder. Ich werde einen Link im Beitrag über die Doku hinterlassen. Danke erstmal für Deine Anregung.

photo
1

Hi Gynta, the text has been rewritten to get more clarity and understanding. However, not exactly according to the proposal in the helpdesk topic.