Navigation does not work

Ladislav Čapka shared this problem 7 years ago
Solved

I had a strange time all the monday while I was driving from Moravia to the Prague. I tried to start navigation at least 15 times during the travel without any success.


The problem doesn't depend neither on current position nor target address/position - I tried more cities/places as target during travel.

I tries two possible types of target place: Set text address and set GPS position (e.g. by clicking on the map).


I've been trying OSRM and MapQuest sources for navigation with following possible results.


1) Result is nothing - most of the time. After I click on "Fast", sometimes there was dialog "Working ..." (sometimes wasn't) and then just map view as before - no error, no navigation active...


2) After "Working ..." dialog, the result was error 200 with text like "navigation has failed".


3) After "Working ..." dialog, the result was error 400 Bad Request.


4) There was a good result, but "Distance to target" was >15 300 km and navigation was lost (icon of big question mark as a next route junction). Moreover, "Time to target" was changing every second like random number generator.


I've partially successeded with BRoute. Navigation worked but "Time to target" was wrong - at the beggining the value was 7 hours (while there was 120 km left and speed ~120 km/h => should be ~1 hour).


I understand you can't solve problem of the OSRM or MapQuest service, but I'm not sure the problems come from all the navigation sources...


* Locus exit/run didn't help.

* Phone restart didn't help either.

* During all these tests I've beed recording track (by Locus) with good accuracy, so GPS signal wasn't wrong.


---

Locus Pro 3.0.2

Android 4.0 (HTC Desire S, original ROM)

BT GPS (Bluetooth served by Locus itself)

Replies (9)

photo
1

Hello Menion,

I investigated navigation troubles with Locus 3.1.0. so I can provide you more information.


MapQuest

Works at the moment.


OSRM

Does not work.


A) Itinerary is OK, but it seems like GPS offset (or similar value) for navigation from OSRM is somehow wrong.

- There is still icon of big question mark for next junction.

- "Time to target" is wrong.

- "Distance to target" is wrong (like >15 000 km).

- Navigation route is not visible anywhere on the map.


B) From time to time I can see error 404 bad request. This happens mostly as recalculation of navigation.


Global

Sometimes still happens confusing error (1) - after working dialog, there is no result. Can this be connected with bad internet connection (e.g. slow/bad GPRS)?

photo
1

Hello Ladislav,


thank you for a precise check. Seems that OSRM changed how coordinates are in their repsonse and Locus incorrectly computed route coordinates. Result was not 50 longitude, but 500!. Which caused, that track wasn't visible, distance was a crazy value and probably also a time.


So this issue will be fixed in next version, thank you!


Anyway it still not solve issue you posted in first post. Is this still happen or it was just some weird temporary problem on MapQuest server?


I may anyway confirm, that I also few times saw, that Locus compute, compute, loading ... and in the end .. nothing happen. But this was so rare issue, that I wasn't able to simulate this problem.

photo
1

>I may anyway confirm, that I also few times saw, that Locus compute,

>compute, loading ... and in the end .. nothing happen.

By the way, could you modify the algorithm in the way that in such situations the Navigation panel (From, To, etc.) is reopened so that the user may modify it and/or restart the calculation ?

I have experienced a few times such a situation that I had set the task for the navigation (From, To etc.) in rather complicated way and did not notice that mobile data was switched off. After Locus found out he could not compute the route I could start over which really drove me nuts while driving ...

photo
1

:) sure - I have this already on a paper (more then once) and I always forget to fix it once I'm at home ...


I'm going to fix it right now, till I forget again ...

photo
1

Hello Menion,

the issue with MapQuest sometimes happens. It seems like failing for specific locations (e.g. MapQuest is not responding in some cases, response is wrong, ...).


If you want me to check it more you could create some request/response log for navigation communication and in case of an error I will tell you what happened. I wasn't able to find those TCP requests in any log so I'm either blind or you are not logging those information :-).

photo
1

Three Czech guys talk in English. Anyway better for foreign guys that may comment this also, but little bit funny :).


So I spend two hours by rewritting part of code that handle request on compute and I believe now it will be a lot more issue-resistant. Every unsuccessful result of "Navigate to" will return back to "Navigate to" screen. So you should improve request or simply end navigation by "back" button.


Issue on MapQuest - yes, there are currently no logs, they're completely disabled in public version. Anyway best is to give me exact first and last coordinates, so I can simulate it and "fix" if issue is on Locus side.

photo
1

Language is not important, important is understanding :-). So, thanks for rewrite! I will check it.


Anyway, you can send me .apk "debug" version if you need some assistance.

photo
1

One more question - what is expected release date for a new version? I'd like to try it :-)

photo
1

Probably this week will be beta version if you're registered as beta tester https://plus.google.com/communities/105669867009952671671


And release - maybe next week. But I do not hurry now, so better "somewhere next week, when all major problems will be fixed"

Leave a Comment
 
Attach a file