No voice on navigation for online and offline maps

Ricyro shared this question 12 days ago
In Progress

Hi,

Any help appreciated.

Using the pro version of the app I am not getting any voice commands when using navigation. This is for all types eg either go to a point, or after plotting a route or for following a save track. I use bbrouter for offline but am also not getting any voice if using online maps. I have uninstalled and resintalled bbrouter and also reset and set again the app settings. Please see attached for my settings. Phone Moto g5.

Comments (4)

photo
1

Hi,

go to your phone system settings > text to speech > check the TTS engine is up and running, using the right language. Then go to Locus settings > Language&Units > text-to -speech > check the system TTS engine and your language is selected - green "ready to use" is highlighted - check it with the test phrase.

best regards

MIchal, Locus team

photo
1

Thanks. I have checked these settings and they are working. I can hear the test phrase 'Do you like Locus'.

Also in Locus if I set the voice to a name I always get the phrase 'You have reached your destination'

photo
1

Hi,

do I understand accurately that both TTS or voice file (Jane) are set up properly but there are no navigation commands on the route? If yes, please check following:

- "Navigate to" feature (used when navigating to a particular point/target) - when starting the feature, open the "show more" part of trhe dialog and check your have "navigation" selected in the guide mode:


8e033923b0287acf440ca398964aaf67


- "Navigation" along an imported route - go to Locus settings > navigation > advanced > frequency of commands > set "low" to "high" according to your needs ("none" - no commands)


fd225cbf958cb43b9dc842faf422374f

best regards

Michal, Locus team

photo
1

Hi Michal

Yes you understand correctly.

I have checked the settings and can confirm they are ok.

If I test and simulate a route with the gps turned off I get the beep if off route but no voices.

photo
1

Hi Ryciro.


Do you test in real use conditions or only by "on sofa" simulation ?


To simulate without gps by map shifting around the center cross.

Locus off.


Find in Locus main directory config.cfg

Than In UI & Utils change.


# set speed for moving cursor on map when GPS is off (in m/s) (default: 0.0)


# - value <= 0 disable this feature


speed_for_moving_cursor_when_gps_off=5.0

Start Locus > Simulate.

photo
1

I test most in real life.

Thank you for the simulation settings they are a bit complicated for me. I will just test in real life.

photo
1

Hi,

then I'm sorry, I'm not able to simulate your problem. When system TTS/LOcus TTS is properly set, and all recommended settings are on, voice navigation normally works. Will test some more and let you know if we get something.

best rerads

Michal, Locus team

photo
1

OK, thanks. I did some more live testing yesterday. I created a gpx track outside of locus and then imported into locus. I then navigated/walked the route and the voice worked.

I then used navigate to a point for a car journey and the voice didn't work.

I then retested the the walking route and no voice this time.

Thanks for your time on this. If anything turns up in the future let me know.

photo