Offline route plannig does not work well

Yuval Yunovitch shared this problem 58 days ago
In Progress

Hi Im using Locus Map Pro v 3.38.4 on Xiaomi Redmi 6, Android 8.1.0 011019

Tried to use offline rout planning using BRouter data source, but most of the time when Im trying to add a point to the rout its trying to add the point and not compltiing, as well as recallculating the route doesnt work at all.What can I do to solve?

Comments (1)

photo
1

Hi Yuval,

we know about this bug and it was already fixed. Now it is being tested and the repaired version will be out this afternoon. Sorry for complications.

best regards

Michal, Locus team

photo
1

Ok I will be waiting, thank yoo

photo
1

Hi, Im sorry but after update the problem still persists

photo
1

Hi Yuval,

OK, let's check how you proceed when planning a route:

- do you have BRouter set as the default navigation data source? (https://docs.locusmap.eu/doku.php?id=manual:user_guide:functions:navigation:settings)

- are BRouter navigation data downloaded? (https://docs.locusmap.eu/doku.php?id=manual:faq:how_to_navigate_offline)

- in the Route planner - is any automatic drawing profile selected? (https://docs.locusmap.eu/doku.php?id=manual:user_guide:tracks:planning#drawing_instructions)

- if you use "Navigate to" feature - do you have auto-recalculation set up? (https://docs.locusmap.eu/doku.php?id=manual:user_guide:functions:navigation:settings#route_re-calculation)

photo
1

Thanks for replying,

It only happens when I use choose to use Locus profiles "Walk" or "Hike" at the Brouter settings, if I use Brouter profiles it works allright. Pics attached

photo
1

Hi Yuval,

in your first screenshot the BRouters profiles are selected and the second screenshot shows no automatic routing - does it mean BRouter profiles don't work? I tested both Locus and BRouter profiles and both working:

429d675c997620a6a7d65402903f5522

photo
1

No, the map screenshot shows the attempt to route after choosing "Walk" profile, using Locus profiles at the Brouter settings. Look at the the "circle" button of routing, it keeps "thinking" but no automatic routing happens.

Again, this is only happens after choosing "walk" or "hike" ftom locus profile. When using other locus profiles or Brouter "walk" profile it works well...

photo
1

I tested it again on both Locus profiles and BRouter profiles and all works... check this video: https://send.firefox.com/download/d2c7c789ec11f0c7/#uWzHXTBwDtjrBWmeXimOlg

photo