OpenAir txt file import does not work

Janne Pakarinen shared this problem 4 years ago
Solved

I have tried to import an openair txt file but it does not work. I have succesfully done this on an older version of locus but no success any more.


I have the attached file in my MAPITEMS folder and when I try to import it on Data / ITEMS page, I get a message saying:

" Problem with file '/external_sd/Locus/mapitems/FinlandAirspace13NOV2014.txt'! " and it does not get imported.

I have tried with several different openair files and I get the same problem. Is this a bug in the current version (3.10.3) or am I doing something wrong?

Comments (10)

photo
1

Hi Janne

see

http://www.winpilot.com/usersguide/userairspace.asp

i found two problems in your file

1. Airspace class AC G, isn´t discribed, i changed it for test in D

2. Airspace class AC GP, isn´t discribed, i changed it for test in D

see modified file

Wolfgang

photo
1

EDIT:

G > Glider, GP > Glider prohibited

both exist, sorry

i think that these values are not discribed inside Locus, so maybe menion can add this parameter to solve your problem

photo
1

Hi,


As balloni55 pointed out, the problem is with G and GP. Thanks for figuring that out. I split up my airspace file into separate files so that I have G, GP, R BY NOTAM and Q BY NOTAM in their own files. This is pretty convenient as I can select which airspace information is to be displayed.


I hope the issue with G and GP will be easily fixed.


Janne

photo
1

There also seems be an issue with openair format "AT"- record which defines the position where airspace label is displayed. When I have two airspace segments that are identical in shape and one is on top of the other, the labels are also at the same place and one is on top of the other and this makes them unreadable. I tried to use "AT" as in the third segment of the attached file, but it does not have any effect on the label position. Is "AT" not supported by Locus Pro?


Janne

photo
1

Previous file with windows-friendly line breaks attached.


Janne

photo
1

Hi guys,


only "G" is missing. Thanks for report and testing - fixed. Btw. is there any usually used color/style/width of "G" line?


Problem with AT - cannot confirm. As I see, AT should be correctly used. Please try to test if change of this parameter has any effect. As I see, only one area in file has defined AT parameter, so suggest to define it to all three to see any changes. Otherwise Locus compute center of bounding box of area to define where text should be drawn.

photo
1

Hi menion


  1. Btw. is there any usually used color/style/width of "G" line?

e.g. see german ICAO map

http://www.daec.de/fileadmin/user_upload/files/2012/fachbereiche/luftraum/Segelflugsektoren/nuernberg_ost_12_mar_09.pdf


photo
1

Hi,


As I recall, G on map would be bordered with a thin blueish line and would have a label with the segments name for example "G07"


Finnish airspace structure changed less than a year ago and new structure does not actually have G airspace anymore. Former G airspace segments are now somewhat simular D segments so it looks like I will not have problems with this when I use a file that is more accurate with the actual airspace structure. But the issue is worth fixing with other areas than Finland in mind.


Janne

photo
1

Oki guys, thanks! It will be improved/fixed in next version.

photo
1

Is this function stopped ?I tryed import airspace file(openAir) many time, but everytime goes failed(w/o choice selection)

photo
1

Good day Pista,

did you used this feature before? It should not be used over "import" feature. Instead use "Items". More about it: http://docs.locusmap.eu/doku.php?id=manual:user_guide:items . Hope this helps.

photo