POI alert: "STOP" button disappearing

Sebastián Ramírez shared this problem 7 years ago
Solved

I set the POI alert on, and when I'm close to a POI, the alert starts ringing. I configure it to ring until it's stoped.


But to stop the alert, I have to open Locus if it's closed and tap the red "STOP" sign / button.


But the "STOP" sign / button appears only when the alert sounds and disapears again, so I have to wait, staring at the Locus screen, until the "STOP" button apears again to tap it.


I would like if the "STOP" button didn't disappear once an alarm starts ringing, so I can stop it without having to wait for it to ring again, staring at the screen. Even better would be to be able to stop a ringing POI alert from the notification bar. Maybe swiping a notification to the side.


POI alert is the main reason why I bought the Pro version, but I would like if it was easier to use.

Replies (5)

photo
1

Good day Sebastian,


I'm checking POI alert precisely, because from your description isn't perfectly clear, why such problem happen. And seems that probably same problem only happen when you rotate a screen. Maybe during that time, screen is turned off and you have device in your pocket.


If you may confirm, then I found out a reason why this happen and issue will be fixed in next Locus version probably next week.


Thank you for your report.

photo
1

Hello Menion,


I see, I just opened the application and it seems working OK.


I think I was misunderstanding the behavior.


First, I have the "POI alert" configured to "notify until stopped".


Let me tell you my full "workflow":


* I get out of home and I hit the record button in the "track record" widget in my main screen.


* Once I arrive my destiny, my phone starts beeping (the "POI alert" reminds me to stop the track recording).


* I unlock my phone and hit the stop recording button.


* I set the track name and hit save.


* Locus shows me the current track screen.


* Since I arrived and until now, the phone has been beeping. I hit the back hardware button to go to the Locus main screen.


* (Here's the problem) Even though the phone has been beeping (because of the POI alert), there's no "stop" red button (yet) in the main Locus screen. So I have to wait until the next time it beeps (30 seconds), for the "stop" button to appear and be able to touch it.


I'm sorry for the long detailed explanation but I wanted to give you the full "user story", so you can replicate the bug / problem.


Being able to hit the stop button right away once I see the main Locus screen would be OK.


The best option (for me) would be to be able to stop the beeping from the notification bar.


Normally, when the POI alert is on, there's a persisting POI alert notification in the notification bar, but when I touch / hit it, it only allows me to configure the POI alert settings or to "Terminate", wich sets the POI alert completely off. What I would like to do, is be able to stop the current alert but leave the POI alert system on, so it alerts me when I'm close to the next POI (e.g., when I get back home).

photo
1

Hello Sebastián,


thanks for a precise description. I believe that my fix will help here and you will always see a STOP button on map, when any alert will be active.


About idea with extra button in context menu - I believe that when red STOP button will work, such extra option won't be necessary.

photo
1

It is working now. Thank you.


I don't see a way to close this issue, but just wanted to let you know so you can close it (if necessary).

photo
1

Perfect, thanks for confirmation!

Leave a Comment
 
Attach a file