Popup af the points/tracks don't appear in 3.14.2

Lucio Dal Pan shared this problem 4 years ago
Solved

Hi guys,

When touching a track on screen map the popup chosen as an option in "Settings/Maps - Objects and styles" doesn't (always) appear as it did before the last version (3.14.2)

Best Answer
photo

One of the worst issues last months ... fortunately I was able to simulate it on older SGS2 . After day of testing ... finally solved. Thanks! (btw. seems to be more issue in old Android version and can't understand why this don't happen earlier).

Comments (11)

photo
1

Good day Lucio,


to be completely clear, you simply tap on a track on a map and small popup do not appear always, right? Instead of this happen something or just "nothing"? There should be no change in latest Locus version and also till now, no one complained about this (which is not important, just an info).

photo
1

Hello Menion.


Yes, when I tap on a track something does happen: the track is highlighted, the point where I tapped is highlighted even more, the same way that in edit mode.

If I toggle between popup mode and edit mode, and back again, the popup appears; but it isn't the first time, and I don't know if this is stable or not. I'll tell you if it is.


(And of course, this is the first complaint about this problem, but also this is the first day of the release: we have time to find bugs and even to fix them =D )

photo
1

Good day Lucio,


last two days I was using Locus during work and testing. Unfortunately I was not able to simulate such problem not a once. To fix this problem, I really need to be able to simulate it on own device with some exact steps. I'll be watching this, anyway for now, I have to leave it be, sorry.


If you find in future any hidden key, after exactly which circumstances, this problem happen, please let me know. Thank you!

photo
1

there is definitely a small problem.

if you need - attaching a video clip with this problem

photo
photo
1

Good day, Menion,


I tried again to understand what's exactly happening, and saw this strange thing:

as you can see in 01.jpg image attached, when I tap on the track it is highlighted the way I told you, but popup doesn't appear; popup does appear if I double-tap on map screen to show upper and right panel (img 02.jpg).

The same thing happens, but in the contrary way: if I tap on the track when upper and right panels are yet visible (img 03.jpg) the popup doesn't appear, but does when panels automatically disappear (img 04.jpg).


Shortly: popup doesn't appear at the first tap but just if the status of upper and right panels changes.


Now I can't say if any other event on the screen works the same way, making the popup appear or hide.

I can confirm that this doesn't happen at the very start of Locus, but only after some action.


For the moment I solved modifying the behaviour of "tap on track" option to "Edit mode": in this case the popup always appears, the name of the track, missing in the popup is visible in the upper band, while in the bottom one I find useful commands to edit track.


Thanks for your attention

Bye

photo
1

Hi guys,

i spend time on it and can reproduce it

requirement:

settings/Map control&panel/MAP SCREEN-PANEL/Top panel hiding is enabeled

and timeout is set e.g. 10s

- display a track on map

- double click on map > top panel is visible

- each click on track > label is visible even top panel disappear

- click once on map > no label is visible

- double click on map > top panel is visible, wait till top panel disappear

- single click on different track points no label is visible as Lucio obseved

but if you wait ~ 25 sec a label appeares alt last track point you have clicked and also on each next click

i hope it is understandable and reproducible for you

Wolfgang

photo
1

@balloni55: thank you for a very precise description. Unfortunately even with it, it still works for me. I've tried it on three devices, now also Petr and Hanka and it works for all attempts.


Has anyone experience with same problem on clear install? Anyway I can't imagine, what may cause this. Mainly such randomly ... :/

photo
1

Problem still exists in new beta on my good old rooted SGS2 4.0.4 with stock rom and on VM with the "androVM_vbox86p_4.1.1_r6.1-20130222-gapps-houdini-flash" android image.

Current (strange) solution is to disable "Top Panel Hiding" in Locus settings

(quote)

Hides the top panel when inactive.

Double tapping on the map displays it back provided the Map Control Mode is set to Locus Map mode

(/quote)

@Lucio

May I ask you what hard/software do you use?

@Menion

I know, you guys arn't able to reproduce this behavior

photo
1

additional i found problem also with POI´s

- at first attempt when top label is hidden each click on a POI open the label

- double click on map , top panel is visible ( sec 11 + 25)

- as long as top label is visible each click on POI open it label

- as soon as top label is hidden opening POI label didn´t work. ( >sec 20 + 32)

see screencast

https://www.dropbox.com/s/trykk605zl34aym/POI_label.mp4?dl=0

my Device: SGS2 Android 4.0.3 IceCreamSandwich

photo
1

My device: Asus PadFone, Android 4.1.1


(Lack of memory switching between heavy apps, such Locus and, for example, Chrome: don't know if it can help)


@balloni55:

I tried to reproduce the situation you described above. I can wait minutes, label doesn't appear.

photo
2

One of the worst issues last months ... fortunately I was able to simulate it on older SGS2 . After day of testing ... finally solved. Thanks! (btw. seems to be more issue in old Android version and can't understand why this don't happen earlier).

photo
1

it works in new beta...

photo
1

Perfect, really glad to hear it, thank you with help!

photo
photo
1

And include track is same problem : try to click open is very difficult !

oh...my god...This is big trouble to us.

photo
2

Hi, I've merged your topic into this, cause it's same issue. Sorry for a troubles ... oh...your god, issue fixed!

photo
1

Fixed ??? How fix ?

Sorry, I have careful read this page however I don't find how to fix the problem !

Or fix it on next release ?


Merged is no problem and this is very great support web paga. Many thanks.

photo
2

Ah sorry it is not clear. This topic was intensively discussed during last few days. So issue is already fixed in Locus source code, but you have to wait on next release. If there won't be any problem, I would really like to publish new version during this week (maybe during weekend).

photo
1

Ok no problem, that's great .

Because I did not come here for a long time till find the problem. ^_^

And I have search similar topic however I don't find this topic before I submited the problem.

So, thank you for merged it.

And the URL of topic is same active for me , That is very great.


BTW, what language is your source code ? C , java or other ?Only a little curious. Thank you .

photo
2

Fine.


Source code ... I'm from 99% Java developer, so most of code is in Java. Some security tools are in C++, some external libraries are in Java, some are in C++, our server is also mostly in Java and some help tools around Locus are usually in Python.

photo
1

Great , thank you ..

photo