Problem with custom directory for 'mapItems'

Kevin Gunde shared this problem 11 months ago
Solved

I just installed Locus Pro on a fresh Samsung Galaxy Tab A (2016) running Android 7.0. I downloaded a local offline map, then I downloaded an image map. I set four calibration points, but when I attempt to create the image map I get the orange box with the phrase: Problem with custom directory for 'mapItems'. The mapItems directory is in the default location the installation placed it, which is under the Locus directory. I loaded a gpx file into the mapItems directory from within Locus (Map items + function), and it copied and loaded it just fine.

Comments (18)

photo
1

I just tried the same process on a Moto Z Play running Android 8.0.0 and it worked perfectly (other than having to deselect 'Optimize Map'). The directory structure of the two installs appears identical.

photo
1

I have the same problem when calibrating an image map. All works fine up to the point where the map should be stored to the MapItems folder. I get the same error message.


This used to work flawlessly before, I have many calibrated maps in this folder. I never changed the folder.

I'm on Android 5.1.1.

photo
1

I confirm the problem. :-(

photo
1

I confirm it too...

photo
1

Good day Kevin, others,

sorry for this stupid issue. I was fixing a different problem and this is an unwanted side-effect.

How crucial is this feature for you? Because it is only a known serious problem in the latest version, I planned a new version after few weeks. In this case, I may create a special version for you here or just give here previous version 3.33.2? Let me know. Thank you for understanding.

photo
1

I can also wait till next major version, thanks for fixing!

photo
1

Thanks

Now functioning again!

Android 7.1.1

/Göran

photo
photo
1

Happy to know it will be fixed in a couple weeks, and it's not something dumb I have done. Can't speak for others, but I can wait a few weeks.

photo
1

I installed version 3.32.2. Problem solved. I can wait.

photo
1

I have the same problem, usually I need this functionality once in a month.

But today is that time of the month :(.

How do I find the previous versions' apk?

photo
1

Here it is, version 3.33.2

photo
1

That was fast, thank you!

photo
1

Thank´s for older version. Enough at this moment.

photo
photo
1

Oki guys, thanks all. I'll try to speed up update little bit, but good to know for me, that it is not too hot.

Thanks and have a nice day.

photo
1

First time I (try to) use map calibration and ... just found this issue ! But I will wait as well. Very nice that I could spot the problem with this Help Desk forum !

photo
1

The problem is still present in current Beta...at least on my device.

photo
1

beta 3.34.1.2. Calibrator creates a map.

photo
1

Look here, especially here.

photo
2

Is this still going to be fixed? I actually used it often. Thank you for any info.

photo
1

It's already been fixed, the fix can be tested in the Beta version. Nevertheless, today or tomorrow we are launching new Locus Map 3.35.0 where this is fixed too.

photo
1

Is I wrote above, the issue is still not fixed for me in 3.34.1.3! :-(

photo
1

You have defined default directory for mapItems in menu > settings > misc > directories and still see this warning about invalid directory?

photo
1

Yes, I have configured CUSTOM directory for MapItems (on ext SD) and creating a calibrated map still fails in current beta. Could there be a problem because it's the same directory configured in pro? I think I never used map calibration in beta before...so maybe it's not a new problem?

photo
1

Thank you very much! Awesome App!

photo
1

@zossebart, and this is the problem. "Custom" directory on SD card cannot now work for creating new content, so please, use default directory in internal memory and I'm sure it will work correctly. I'll have to improve this but for now, there is this limitation, thanks for understanding.

photo
photo
1

Yeah but I used to use this setting all the time and suddenly it doesn't work anymore? Note that the custom directory is "/sdcard1/Android/data/menion.android.locus.pro/MapItems" which should be writeable (at least by locus pro). Ok I see locus beta shouldn't be able to write it.

I think there really was a problem in pro, you fixed it in beta, but my test can not work because the directory is set to a pro-writable directory in locus beta (as I wrote before, I think I didn't use this feature in beta before)...I'll wait for next pro then...

photo
1

Ah here comes problem :). Yes, this is correct. Beta version extends Free, so it uses name "menion.android.locus" and needs also a directory with the same name.

Pro version was published today for the limited number of users to verify it's without serious problem. To global public will be published tomorrow.

photo
1

Having the same issue in Pro. Previously created calibrated maps (> 2 months ago) are still working correctly, and they are contained in the default 'mapItems' directory. If I go to create a new calibrated map I get the error. All other defined directories are using the same root path, and are working fine.

photo
1

As expected, it's working again in new pro version! Thanks again!

photo
1

Update 3.35.0 Pro solved it for me.


Thank you.

photo
photo
1

when do you expect the problemm will be solved ? thanks

photo
1

I've just download 3.35.0 and it's work fine now

thnaks for the job

photo
1

Also solved for me in 3.35.0