Problem with gpx 1.1 export data

Alberto Poggi shared this problem 6 months ago
Closed

When I export the data in gpx 1.1 format, the "descr" field contains incorrect information that can not be used when importing it as a shape file. This did not happen before the app was last updated. Can you correct the error?

Files: test.gpx

Comments (7)

photo
1

Good day Alberto,

this is really interesting. How this point was created? There is an issue in generated description anyway it looks like this point was maybe long time ago imported from any older GPX file that already had a description?

Are you able to simulate this issue with completely new created point?

photo
1

This point was generated as a photo point from the application.

The description field has been completed correctly.

I use for work this kind of point for insertions in a gis system that uses Quantum gis as a management program.

Basically, I export the detected photo points with the "desc" field as gpx and then I import the gpx file into quantum gis.

This is where I find the "desc" field with incomprehensible strings of text.


The version of quantum gis used is the official 2.18.16 but I also tried with the new version 3.2.3 with the same result


I attach new test.gpx test file with 2 points.


The first point with the empty "desc" field


The second point with the "desc" field filled in


The phone used is a huawei p10 lite officially updated with android 8.0.0

Thanks

Files: test.gpx
photo
1

Hello Alberto,

the issue is definitely in first GPX file you send, not in QGIS app.

Your second "test.gpx" work correctly right? It looks perfectly valid so should work without a problem.

In first "test.gpx" is description really incorrectly formatted. If you look inside, on line 26 is some part of the old description that says that point was created 11. May 2018. On the line 35 is the date when the new point was created as 16. October 2018 , so there definitely was "something before".

For me, it is impossible to simulate this issue without exact steps, sorry.

Does this happen for more points or just this one?

photo
1

I'm sorry but the second file has the same problem.

if you import it in quantum gis you will notice that in the "desc" field of the first point, which should be empty because I have not filled it, instead it has a text.

The second point, where I enter the text "test description", has the same problem as the first in the sense that the text that you see in the "desc" field is not what I wrote during its compilation.


I attach an image of the error

photo
1

Excuse me I found the mistake.

I had flagged the entry "Include description & attachments".

If I remove the flag, the export works correctly.

The title of the flag misled me


Thank you for your quick reply

Greetings

photo
1

Oki perfect.

Anyway, the first file will maybe work if you uncheck "Include generated description", but generated (attached) file is definitely invalid and I have no idea how to simulate this issue. So if you find out a steps, please let me know. Thanks.

Btw. if you work QGIS, you may find useful this app we work on: https://play.google.com/store/apps/details?id=menion.android.locus.gis

photo
1

I confirm that you just remove the flag under "include descriptio & attachments" because everything works fineI will try locus gis. Thank you

photo