Problem with map adding: Error: Uknown problem

myneur shared this problem 5 years ago
Solved

1. four tar maps copied in „personal maps directory“ on SD on KitKat (just .tar files, nothing else)

2. every start shows dialog with bunch of errors: Problem with map adding: Error: Uknown problem (screenshot)

3. those maps work but every startup shows the same errors


Suspect: KitKat SD card is read-only and Locus is trying to write something that?


Similar errors were if I added there a .sqlitedb maps without .sqlitedb-journal

But I don't have any -journal files for those maps now.

Comments (11)

photo
1

Hmm i'm testing it and for me, TAR maps on read-only external SD card works without a problems.


May you please check if map files are really correctly transfered on your card? If so, I'll need a log from you.

photo
1

Maps seam OK. They also display fine in Locus, I can use them.

See the strange thing in screenshot: map name is „SR-14.tar“ but the error is about „._SR-14.tar“, and there is no such file there.

photo
1

I plan to release a new version probably tomorrow, but may you create for me a log where will be these errors you see during a start? I'll check them immediately and maybe fix to next version (if it will be possible)

photo
1

CatLog now seams to require ROOT which I don't have. Any other option to get the log for you?

photo
1

Here you are

1) reproduced

2) take bug report

3) sent

photo
1

Hello,


thanks for a log. I've checked it right before publishing new 3.1.1, but seems to be something on long evenings, so it won't be fixed in new version yet, sorry.


Anyway in logs is really visible, that Locus tries to add maps with name you wrote, something like "._map.tar". And I'm unable to find a reason, why isn't used real name of file.


May you please try to simply add maps to different directory on SD card? Just a play little bit with them. Because for me, reading TAR maps from read-only SD card works, so there have to be some tiny difference that cause these troubles. Thank you!

photo
1

Ha! I got it!


Files prefixed by „._“ are hidden system sidecar files from OS X/Unix HFS+/UFS containing metadata which are not possible to manipulate by user manually. They are not visible even by ls -al like files starting by dot, but they are being copied even to file-systems which does not need them.


http://apple.stackexchange.com/questions/14980/why-are-dot-underscore-files-created-and-how-can-i-avoid-them


1. I copied standards .tar maps from OS X, so these mysterious files were copied silently.

2. Locus seams to treat these files like ordinary maps and tries them to load.


Cure:

I removed those files and I have copied the maps through Google drive instead. Now no errors are there.


So the problem is a combination of these mysterious hidden files which are being copied from OS X and locus treating them as standard maps.

photo
1

This is surpising solution and good to know information.


I'm really glad you solved it :). Perfect.

photo
1

Hi, could you help to remove the error message prompt? Each time the app starts I am prompted with this message. The location of file (I mean on SD card) does not exist. Can't delete it. I don't use thw map, wish to get rid of it.