Problems Downloading from Store

Darrow Kirkpatrick shared this problem 22 months ago
Solved

I have a fresh install of Locus Map on a new phone. I downloaded 3 United States LoMaps, no problem. On the 4th map (Utah), I get "Waiting..." for hours. I tried a 5th map (Arizona), same message. If I check Ongoing downloads I see the same messages for those maps, and for my 3rd download (Colorado), which did download successfully. I tried completely uninstalling and re-installing Locus Map, and get the same behavior. It seems I cannot download any more maps. The phone has lots of free storage. Can you help?

Comments (5)

photo
1

Good day Mr. Kirkpatrick,


I've just tried to download a Colorado map on own device and it seems to work correctly. In these cases, when application doea not display any error message, it is quite comllicated to find a solution.

May I ask in firat stwp, that you simply try to restart your device? This quite often helps.

If not, we may try to create a debug log by thia method : http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log


Thank you and sorry for a complications.

photo
1

Thanks, I have emailed you the debug logs separately to locus.map@asamm.com titled "Kirkpatrick / Problems Downloading from Store / Bug Reports".

Additional background: I am a long-term Locus Map user. I installed your latest version on a new Google Pixel 128GB phone. I downloaded New Mexico and California maps, no problem. Then the Colorado map appeared to download correctly, and is usable, but still shows “Waiting…”. I then tried downloading Utah and Arizona maps and they do NOT download, and continue to show “Waiting…”.

I have tried restarting the phone multiple times, and uninstalling/reinstalling LocusMap. Also, I have tried deleting the Colorado map and re-downloading.

Thanks for your help.

photo
1

Ok, I finally got this working by using Clear Cache and Clear Data from the Apps manager, uninstalling Locus Map Pro, deleting the entire Locus folder tree using an external file manager, restarting the phone, and reinstalling. I still saw some weird behavior like multiple downloads, and the Maps list not refreshing, but perhaps those are from leftover requests. Anyway, the app seems to be functioning normally now.

photo
1

Good day Darrow,

firstly thank you for a logs. For my big surprise, I was not able to find any error information inside. It looks like app does not report any problem, it just hangs and waits for something. In such cases, I usually try to prepare special version that print out into logs more information that may helps. Anyway as I see, you have invested some more time and made complete re-install. I did not expected this, but seems it help, perfect!


Problem with remaining multiple downloads and refresh of list should be solved in next Locus Map version. Btw. what about your old maps and data? Did you made a backup of this directory before delete? Because by simply deleting whole Locus Map folder, you loose all recorded points/tracks ( stored in Locus/data/database directory ), so I hope this is not your case.

photo
1

Thanks Menion. This was a fresh install on a new phone and I had not brought my old maps and data forward yet, so no problem. I do like Locus Map and will look forward to continued updates!