Quick theme selector not showing

GarenKreiz shared this problem 5 years ago
Solved

Hello,


I experience the problem when trying to use the new Elevate3 theme from Andromaps. After manually installing it on the right directory, I was able to choose "Elevate SVG" for an OSM based vectormap.


The theme didn't work (just displaying several "Loading.." message). That may not be a Locus Map problem if the theme itself has errors. But one consequence was that the bottom left "Quick Settings" menu disappeared making it more difficult to go back to a theme without bug.


I checked the "Map - control & panels" settings: the "On-screen map themes switch" was set. I had to search the support site and find the "long press" trick when choosing a map to be able to switch back to an internal theme and to make the "Quick switch" menu visible again.


By the way, the "long press" action is not available when one chooses a map from the "Quick map switch" menu.


Regards

Replies (7)

photo
1

Hello Garen,


I'm not sure if this is a problem at all. In case you supply to any application invalid data, you cannot expect it will work correctly in all cases. So in case, map theme was invalid, you just have to fix it manually. Theme selector on main screen is visible only in case, currently visible map has correctly set theme. Which wasn't your case.


So I don't know to be true, how may I help here.

photo
1

For me, the theme selector is related to the map not the current theme. If the map is correct, the theme selector should be always available (at least the top menu), especially to cope rapidly with bad themes. Only the sub menu that are specific to some themes (to choose layers for example) should be dependent on the theme being correctly loaded.

But if the implementation is difficult or if it breaks something else I understand. In any case, I'll try to contact AndroMaps as they provide themes that should work correctly on Locus.

Thanks for the quick response you provided

photo
1

Hello Garen,


understand and agree that this "theme select" should not depend on theme, but on selected map. To be true, I was little bit lazy to do it in first moment because such issue was more caused by invalid data, anyway mainly for theme developers, this may be an problematic. So consider it as fixed. Thanks for a "bug-report"!

photo
1

I was considering beginning to tweak themes to try to have maps in France that may look like our paper Topo25 maps from IGN. I'm wondering how one can debug a theme : is there any output for diagnosis other that "Loading..." on the screen?

photo
1

This is more a question on Petr, who creates themes in our team. Petr? Thanks

photo
1

I work with Android monitor that shows the logs from application on the fly. In case of any problem should render prints error message into mentioned log. Use error message to find out more info about theme issue.

How to work with Android monitor app is described: http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log#general_solution_for_all_android_versions

Please note that mentioned article describes how to crate the log files - so please use it only for installing Android monitor and for getting the logs.

photo
1

Thanks, I was not aware of this document.

Leave a Comment
 
Attach a file