This object is in archive! 

Route Planner causing Locus to crash

Alan Budden shared this problem 6 years ago

My device is a oneplus 5 running Android 7.1.1.

I've been trying the new route planner feature (being able to edit routes I've created is the killer feature for me and makes Locus the best app ever in my opinion). However, I've found that it has a tendency to crash, which puts a bit of a dampener on my excitement...

The impression I get is that the problem is down to converting "shaping points" to "via points", but I haven't investigated that much. What I'd like to do is create a route with a few via points and probably quite a lot more shaping points to make sure it goes exactly where I want. I then want to be able to go back into the Route Planner and tweak the route by adjusting the shaping points (and possibly the via points).

It felt like it would be quite hard to describe exactly what was happening, so I recorded my screen three times. The first and third time I converted the start, end and mid point to via points; the second time I just left them as shaping points. As you'll see, the second time worked okay but the other two caused a crash (but interestingly, with no "Locus Pro has stopped working" type message).

Videos here:

1 (crash):

2 (okay):

3 (crash):

Replies (3)


Good day Alan,

what a huge problem you found. For my big surprise, VIA points are not stored permanently at all, they are always lost after save!

I believe I've found an reason for this behavior ( saving of via-points ) and after that, I was no more able to simulate your issue here.

In Monday, we plan new version so let me know if all will work as expected in this 3.26.2 version, thank you!


Hi Menion

I've just tried the new release and it's working now.

Thank you for implementing this killer feature!



Thanks Alan, glad it works. And well ... we are not yet finished with Route planner ;).

Replies have been locked on this page!