SPOILERS and 3.4.0

zoumba shared this problem 6 years ago
Solved

I recently upgraded to 3.4.0.

I'm using spoilersync to prepare my offline images.

I also use GSAK database addon to manage my caches.

I changed nothing on my phone regarding my data managment, but since I upgraded to 3.4.0 I can't get a spoiler pic to load in Locus. I searched but saw nothing regarding a change in that field. Is anyone experiencing something equivalent ? Anyone know something on that issue ?

Replies (12)

photo
1

Good day zoumba,


I'm not aware about any problem with spoilers in latest version.


May I ask you for additional help with this issue? If you may prepare for me GPX file with one point, some spoiler data you expect to see for this point and exact steps what should I do with points & data to simulate your problem, I'll gladly check it and fix it. Thanks

photo
1

Menion,


I built a little example that I uploaded on dropbox. The url is below :

https://www.dropbox.com/sh/qi4am09saevgpty/AACgznE7tlhwy-pM8wRphswHa?dl=0


I hope it's clear enough to understand the situation.


BTW nice app you're designing, I'm PRO for years now.

photo
1

Hello zoumba,


thanks for your sample data. I placed GC5GV1W - Spoiler.jpg file into Locus/data/geocaching/data directory and into same directory I placed also GC5GV1W.html file. After import and display of GPX file with single point, I'm able to see image in spoiler tab, interesting.


On your screenshot is visible, that Locus tries to load html file correctly, but only an image cause troubles. May you please double check, if image is correctly uploaded into correct directory?


Little bit weird is, that you do not even see some tiny empty rectangle, that is usually visible when image is not for any reason available. What I may suggest, is to try clear a cache of Locus app in system settings. Let me know if anything from this helps. Thanks and sorry for a troubles.

photo
1

Menion,


sorry for delay in my answer. I upload my spoiler images in Locus/data/geocaching/<subdir> because I have several "databases". So I have Locus/data/geocaching/<subdir1>, Locus/data/geocaching/<subdir2>, Locus/data/geocaching/<subdir3>... in each I have the .html file and .jpg files generated by spoilersync.

Even if it is on toplevel it doesn't work. BTW I'm running fine on cyanogenmod 4.4.2 for ages, but it's only since Locus 3.4.0 that I have the problem.


I cleared the Locus cache but doesn't change a bit, and tried to move around the files but no chance.


Keep in mind that the phenomenom is the same on all spoilers not just that one.


No worry for troubles.

photo
1

Hello zoumba,


quite a mystery, sorry to say that.


Please, we are planning a new version of Locus on this week. There are no changes around this problem, but maybe update of Locus helps you. So please wait and check later new version 3.5.0.


If result will be same, please

1. try to use "GC Offlinizer" on any cache and say me if images are visible for you or now (GC Offlinizer use same system as your solution)

2. if same, try to un-install Locus and install it again (you may do backup of settings in backup manager, to restore previous settings after re-install).

3. if still same, I'll have to create some special version that will print out debug messages to test and get some more information about this problem.

photo
1

Hi again,


offlinizer works well. it uses the garmin style folder structure <last letter>/<letter before last>/<cache code>/files...

I use the same structure as in the old days several folders <spoiler1> <spoiler2> in Locus/data/geocaching. Structures differ in that and also in the name of the html files.

offlinize uses : images.html in <cache name folder>

spoilersync : <cache name>.html in <spoilerx> folder


i pasted the html code of spoilersync in images.html in garmin like folder structure : things work fine.

i tried to use images.html as <cache name>.html in non garmin like file structure it is KO but now it is identified as spoiler and not as images.


so the thing is that images (.jpg) are not correctly displayed when they are not in a garmin like folder structure and indexed via a images.html file in the same folder, or is it when that are to be displayed in the SPOILER tab rather than the IMAGES tab.


i'll wait for 3.5.0 and check the 3 steps at that time.

photo
1

Menion,


I had been busy these days and couldn't take time for this but for now. And then I happened to run into another issue, that didn't see coming : androidpit (I bought the app there) closed its downloads. I'm a little bit stuck here. I run through there website in a few words they say "contact the developer". I'll run through your site to see if this is already discussed.

photo
1

Hi,


quite interesting problem with AndroidPit. Please check this our new blog post focused on this issue: http://www.locusmap.eu/locus-map-pro-apk-androidpit-users/ . There is also a link to one older post. Hope this will be useful for you.

photo
photo
1

Menion,


I finally (sic) took time to do step 2 (after going to google play and re-buying the pro version).

Unfortunately, nothing changed.


step 3 ?


zoumba

photo
1

I'm precisely checking differences between both methods and I found only a single difference (caused by accident).


Please check menu > settings > geocaching > auto-load images. This settings should have effect only online images, but there should be a problem on Android side. So please check it. Thanks

photo
1

Menion,


you have identified the problem. I had this option disabled in order to save my data consumption. when I allow the loading over the network, everything seems to work ok. nevertheless, this option is not consitent with the behaviour observed. it's some sort of a bug but I can live with that.


zoumba

photo
1

Perfect. I've removed function that support Android itself and created own one, so in next version, this settings should work correctly. Thanks for patience and glad it works now. Uff, this was mystery ...

photo
1

Great.

I'll live with the bogus option until then without complaining :-)

Good thing it was identified.

Thanks for time taken.


zoumba

Leave a Comment
 
Attach a file