This object is in archive! 

Swisstopo maps won't download

Beno Müller shared this problem 5 years ago

Yesterday the download of two newly purchased Swisstopo maps failed. Today, it's still the same. In the case of the Stans map, it always fails at 28% (see screenshot). So far, I've never had problems with downloading Swisstopo maps.

What I tried:

- Removing the half-downloaded DB and tried to download again.

- Renaming the cache folder

My System:

- Android 8.1.0

- SD Card formatted as internal storage

Replies (2)


Dear Beno,

I'm sorry for troubles. Unfortunately we need to release new version to fix this issue and the release is planned for next week (probably on Thursday). Please wait for the new version and after that download map again.

I can also refund the purchase in case that you can't to wait (please let me know if you want to refund).

Thank you for understanding

Best regards



Thanks for the quick answer- and in general for this very use- and powerfull app! I can wait until the release, no problem.

Replies have been locked on this page!