This object is in archive! 

Text to speech in Portuguese defaults to Brazil

kwizatz haderach shared this problem 3 years ago
Solved

Hello! When I try to select Portuguese (Portugal) Locus selects always Portuguese (Brazil) and downloads this last language data.

I delete it in the android settings, then go back to Locus. If wifi and data are off, then in the drop-down list, even if Portuguese (Brazil) is selected (Portugal can't be selected), the TTS is Portuguese (Portugal), but as soon as I turn wifi on, Locus downloads Brazil and defaults to it.

Please fix this in a future release or tell me if there is a way I can fix it.

Regards

Replies (6)

photo
1

Hi,

what language do you use as your mobile phone system language? What language do you have set in Locus settings > Language&units > App language? What language do you have set in Locus settings > Language&units > Text to speech?

Michal

photo
1

Hi,

System - English US

Locus - system default

TTS - English US because, as I said above, I can't select Portuguese (Portugal).

See the screen record I attached.

Regards

photo
1

Hi,

it seems some out-of-Locus setting prevents Locus from selecting the right language... Go to your system settings > language&input > text to speech output > Google text to speech engine > language > select Portuguese (Portugal). Does it help?

photo
1

It is selected. As I said in the beginning, even when I delete Brazil from the system, locus automatically selects Brazil when i choose Portugal and then the system downloads Brazil again.

Other apps are using Portugal perfectly fine. Only locus defaults to Brazil.

Regards

photo
1

Hello,

what an ugly mistake in the app. Thank you kwizatz for the bug report! Issue found and fixed. I found, there were more problems, like missing some TTS languages and duplicate "EN" language. All fixed, so in the next version 3.38, it should work correctly.

Menion

photo
1

Hi Menion, I'm glad you found the bug.

Regards

Replies have been locked on this page!