The lock screen again ...

Lutz shared this question 40 days ago
Answered

I use an Xcover 4s with android 10 and locus 3.46.2, "Screen timeout" is 1 min.

In locus Ssettings | Controlling | Display | Disable screen lock: All screen locks on!

Recording a track, locking and unlocking with hardware button works - locus stays in front.

After "screen timeout" unlocking with hardware button flashes locus but then shows the lock screen!

Comments (3)

photo
1

Hi Lutz,

please check Locus has the system permission to be on the lock screen, to run on the background and to auto-start. Unfortunately, the "All screen locks" settings don't work correctly on all devices (see the notification in Locus settings)

photo
1

Okay, it stays "above" the lock screen (timeout or button), as long as you don't push the (physical) home button which wants to open the home screen (not Locus). In this case the Locus screen will just flash up for a second and then the lock screen comes up.

photo
1

Hi Lutz,

try this (it works on some devices):

- go to Locus settings > Controlling > Display > Screen on/off control - enable and set "auto screen turn off" as you need

- Locus settings > Controlling > Display > Always screen on - enable as "always"

- Locus settings > Miscellaneous > Run Locus Map as service - enable

hope it'll help