Track preview across multiple maps

Ulrich Kiermayr shared this problem 2 years ago
Closed

Hello,


I have a track starting in the Czech republic and ending in Germany. When doing a track preview, the Czech post is missing the map.

Any way to fix this?


Greetings, Ulrich

Comments (1)

photo
1

Good day Ulrich,

this is interesting and unexpected. I'm just testing this and it seems to work correctly to me.


So I have to ask if is vector map auto-loading working for you? This means is missing map automatically loaded when you just scroll the map?


Menion

photo
1

Yes this works.

All the maps are loaded in the main screen. Even the small preview window in the track listing works correctly.

If necessary, I can send you the relevant track.

Greetings, Ulrich

photo
1

Hmm maybe yes, attach me the track here. All seems to be correct in code and it also works correctly for me.


As I think about it, maybe I know where should be a problem. You have some bigger map of Germany from OpenAndroMaps web site right? There should be a problem that Locus tests only a bounding rectangle of these maps if they cover necessary area. This is different compare to LoMaps where these checks are more precise.


Anyway send me a track and write me names of your maps & it's source and I'll try to check it, thanks.

photo
1

Here you are.


Greetings Ulrich

photo
1

Thanks Ulrich, write me please also your vector maps you use ( it is quite important and definitely has influence here ). Best it's names, source and version ( just maps that affect this are, so Czech Republic + some German map ). Thanks

photo
1

Hello,


Those are the maps I installed. Switching between locus maps and openandromaps does not have any effect.


Greetings, Ulrich

photo
1

Good evening Ulrich,

I started to prepare special version that I hope, should tell us more and then I realized that this issue was already here and that it does not have any solution. Problem is that OpenAndroMaps does not have exact definition of it's coverage. Every map has defined coverage only as huge rectangle so it is not simply possible to say if map cover required area or not. And result is what you see. LoMaps are made different and this issue is already solved there.


So sorry, I really have no simple solution on this in case, you use other then LoMaps vector maps. Thanks for understanding.

photo
1

Hello,


I understand that, but: how do I switch the vector map used for track previews? I have both maps installed (locus and openandromaps) and simply changing the map in the main window to a lomap does not seem to have any effect on the map preview (contrary to changing the theme, which had an effect).


Greetings, Ulrich

photo
1

Hello,

it is not possible to define this anyway I at least made yesterday improvements that LoMaps should be used as first before other maps for this case, so we will see ;). Hope this helps ...

photo