Trying to install Locusmap on a Samsung Galaxy Tab Active2

philip underhill shared this question 2 months ago
Answered

Get a "Not compatible with this version" message when trying to install. Version of what? I thought Locus was supposed to work with all Android devices.

Comments (3)

photo
1

Look here ....

Ups .... just found out that your device is running Android 7.1. So there should be no problems running the latest version of Locus,

photo
1

Thanks! You directed me to exactly the right place: https://docs.locusmap.eu/doku.php?id=manual:faq:devices_older_android

My device is running Android 4.4.4 and the latest Locus will not work. The link you shared above does not seem to be available from the locusmap.eu home page and the older versions are not available via the google play store.

I installed the applicable older version that page suggested and it works perfectly.

photo
1

Update: After getting Locus installed and working, I figured out how to upgrade the device to Android 5.1 Locus subsequently upgraded to 3.39.4 and is working great!