This object is in archive! 

Unsuccessful routing breaks routing until app restart (force close needed)

Andrej Bruder shared this problem 6 years ago

Hi, this bug is little bit tricky one. It involves the new route planner with routing turned on. First time this behavior was observed on version 3.26.2 and it is present also on 3.27.1.

Following conditions need to be met.

1. Part of the route has no routing data (or routing is unsuccessful for whatever reasons).

2. You try to adjust the part with no routing data several times (I have experienced this behavior after 4 tries.)

Result: Routing stops working completely (even on parts of the route where it previously worked). What's even more troubling is that after exiting the app, app cannot start - force close of the app (or device restart) is needed to make the app work again.

It is quite difficult to describe the problem in writing, more information see in the attached video.

The part with no routing data is in Západné Tatry between Pyšné sedlo and Blyšť (Slovak - Poland border).

I have also attached zip file with BRouter routing data from my phone.


BRouter routing data:!AGEjImBLVaj7984f

Replies (5)


Good day Andrej,

thank You for a very precise video-bug report, appreciate it!

For my suprise, even with "segments4" directory from your backup and on exactly same place in Tatry, I'm unable to simulate your problem.

What is mainly weird to me, is that on your video is no visible error message. It should appear in case of any problem on BRouter side.

May I please ask you for a small help again? Update BRoute application to latest version on Google Play, update all necessary routing files directly over BRouter app, simulate problem again (if it happen after updates) and if so, generate bug-report log by this method. I hope that in log should be any error message from BRouter or Locus Map itself. Thank you.



OK, I will do it but it can take some time. A lot of other stuff to do right now. :-(


Hi, I have sent you bug report as requested.

This is what I have done.

  1. Uninstalled Brouter
  2. Renamed Brouter folder (just in case I would need a backup)
  3. Installed Brouter from Google Play (v 1.4.9)
  4. Downloaded routing data (all necessary map segments).

Next day I have tried to repeat the procedure. After adding point 2 (as in my video bug report) I have received error "t-service not available" or something similar. I was not quick enough to make a screenshot and did not remember exact wording.

Then I created the 1st bug report.

(Anyway, I have experienced this error before. It started appearing occasionally after latest update of Brouter to version 1.4.9. As a workaround, I need to start Brouter app manually. After that I switch back to Locus and routing always would start working. It was the same this time.)

Then I repeated the procedure and I was able to repeat the bug again in the same way as in my video. After repeating the whole procedure (including force close of Locus) I have created the 2nd bug report.

During this I have realized that depending on the exact placing of the points it can happen that bug will not show up. In order to be more definite please repeat the steps in my video with the following twist:

  1. Before adding point 3, change Drawing mode from "Walk" to "Draw manually".
  2. Add points 3 (Blyšť) and 4 (Bystré sedlo).
  3. Change Drawing mode back from "Draw manually" to "Walk"
  4. Add point 5 as in the video - somewhere on Bystrá or farther. Exact placing should not be crucial until it is placed on marked trail (blue or yellow).
  5. Try to adjust the route between points 3 (Blyšť) and 4 (Bystré sedlo), (not between 2-Pyšné sedlo and 3-Blyšť as in video). Try to keep the new point you are adjusting on the red trail.

If, however, you still will not be able to repeat the error, during the weekend I can make another video with more details.

Hopefully this will help to detect the problem.


Good day Andrej,

very precise description, thank you!

I was able to simulate really similar problem on device of my colleague, perfect.

Seems it is some issue in BRouter profiles, that are used in Locus Map app. As a temporary solution, you may try to switch to BRouter default profiles in Locus Map app. To do this, open Locus > settings > navigation and select BRouter. On right side next to BRouter, choose "Settings menu". Now you are in setup of BRouter router and here in top is an option to use Locus or BRouter profiles. So disable this option to use BRouter profiles. Then try routing and it should work.

Problem seems to be in internal defined "walking" profile. I've updated this to little bit different version that seems to help, so in next version, even an internal Locus Map routing profile should work correctly.

Let me know in next version, if there will be any problem. I have at least a device, where this seems to also cause a troubles.

Thank you and wish you a nice day!

Jiří M. aka Menion


Thank you for your suggested workaround.

I will let you know if there is any problem after next update.


Replies have been locked on this page!