Unsupported File Version for Vector Map with 2.11.0

DougPeterson shared this problem 9 years ago
Solved

I have a problem loading vector maps with the current version (2.11.0) for maps that worked up to the prior version (2.10.2). I believe all of the maps were ones that I had created using osmosis against a poly file against a larger source file, specifically for provinces in China.


FileOpenResult [success=false, errorMessage=unsupported file version, expected:3, header:2]


Thank you,


Doug Peterson

Replies (3)

photo
0

The version of the plugin mapsforge-mapfile-writer.jar file I was using was 0.24. I updated osmosis to 0.40.1 is and 0.30 of plugin and it created a file that Locus worked with. 0.40.1 was the latest version of osmosis that would work with the plugin. Newer versions of osmosis failed with it.


Thank you,


Doug Peterson

photo
0

Hello Doug,


sorry for troubles. It`s an issue in latest Locus version. It`s already fixed and will work as expected in soon coming update

photo
0

The 2.11.1 update has fixed the problem. Thank you for the quick fix.

Leave a Comment
 
Attach a file