Update and install fail with error -504

Mandarax shared this problem 3 years ago
Closed

My tablet is a Samsung SM-T315 and I've been using an unofficial port of

CM12 insted of the Stock ROM since February 2016. It worked perfectly until last week an update for Locus Pro failed with error -504. I followed the troubleshooting guide from Google, but with no success.


What else did I do?

- tried to restore the app from a backup

- tried to install the extracted app coming from another tablet (where the update worked fine) with almost identical hardware

- reset the tablet completely, wiping all data and apps and installed everything again

- install another ROM (Resurrection Remix) and wiping all data and apps

- installed the stock ROM, but failed to connect to the Play Store (the Play Store app in the stock ROM does not work any more and I could not install current GApps)


When installing Locus Pro all I ever get is the error -504. All other apps seem to install and work fine.


Any help appreciated, this is my main navigation device.


Hans

Comments (1)

photo
1

Dear Hans.


Thank you for your email.


An error 504 is a problem on Google Play store side. Unfortunately, we are not able to fix it.

Please, try some recommended method, for example here https://www.androidpit.com/how-to-solve-google-play-store-errors#five-zero-four


Kind regards

Hana