What's default about the new 5.0 vector map default SD folder possibility?

popescu shared this problem 4 years ago
Solved

I was overwhelmed by joy when I read the news about bringing SD maps back on Android 5.0. I changed the default folder to an SD folder, copied all the naps from internal memory there and then wanted to perform an update check from the Locus store. Nothing. No map updates to even check for.

So I tried to buy a new map. But it downloaded to the internal memory and stayed there.


What's the point of setting the SD folder as a default folder for vector maps when it does nothing else than the old workaround with external folder? This is useless. Or am I just missing something?

Comments (9)

photo
1

Hi Popescu, did you re-start the app when you changed the MapsVector folder location?

photo
1

Sure I did, I, wanted it to load the new map location.

photo
1

I assume you have the latest 3.11.0 version and Android 5.0 device... is that right?

photo
photo
1

That's correct.

photo
1

Hello popescu,


have to ask ... did you tried to set it over menu > settings > misc > "Default directories"? What then open when you tap on "Set mapsVector directory"? Screenshot or video should be useful ...

photo
1

Sure, here's it. I followed the settings path in the release info, then I went to the SD card where I have my folder with maps that didn't fit in the internal memory and that I was using with the old workaround. I then closed the app, waited 10 seconds, went to a file manager and moved all the content from the internal folder to the SD one, started the app again and then it did what I said - didn't recognise the maps in Locus store (I can see them and use them, but not update them) and downloaded a new one back to the internal memory.

The problem might be the fact that after selecting the SD folder as the new default, nothing in the settings really changes.

photo
1

Oki, thanks! You are doing all correctly so issue is on Locus side.


What you wrote "The problem might be the fact that after selecting the SD folder as the new default, nothing in the settings really changes." - is exactly the problem. If you have setup directory correctly, it should be visible here.


I've just released new version because of different problem. But I've changed one small function in this new system. This change for sure breaks compatibility on other devices, but it is my risk :). Let me know if it helps.

photo
1

No, the new release didn't solve the problem. There is a change though. Now it says "process unsuccessful" after choosing the folder.

photo
1

popescu, do you like testing? :). Here is one version for this purpose: https://drive.google.com/file/d/0B_Nr4CT8osmtdzN2X2dyNzZlQ28/view?usp=sharing . Try to set this directory as you did before. If it still won't work, please terminate Locus immediately and in Locus/logs directory should be log for me. But I think I've found a reason why it won't work, so ... thanks!

photo
1

It works with this version. After choosing the SD folder it tells me it requires terminating Locus and moving the content manually and I can see the new path in the menu instead of "default". So you got it :)

photo
1

Perfect, thanks for testing!