This object is in archive! 

WMS Problem

Fifi shared this problem 10 years ago

I try to display some maps from a WMS server.

Server type : ARCGIS

WMS version : 1.1.1

Localization : -22.151820 166.735100

Links to the server :

1. Basemap WMS link :

ArcGIS Services Directory :

Number of layers : 1

2. Protected area WMS link :

ArcGIS Services Directory :

Number of layers : 7

What i have tried :

1. WMS creation in Locus : http link ==> nothing happened, no folder created and message "unsuccessful process"

2. WMS creation in Locus : i've read somewhere that Locus doesn't work with Https but same link with https this time ==> Folder is created, selection of layers is enabled but nothing is displayed on the map. Only messages saying "Unknown problem"

So i tried this http links into a desktop application : QGIS. It works fine.

Then, i tried with an another app with WMS capabilities on Android. I installed OruxMaps. These http links works fine in OruxMaps, but Locus is definitly the app i love ! :-)

Any idea why it doesn't works in Locus ?

Spatial reference (3163) of these WMS links ? Something like a User Agent ? (I tried different Android User Agent in QGIS, it changes nothing)

I've also already reported the problem to the support of "carto10" server today.

If someone has an idea ...

Thank you !

Replies (6)


Hello Fifi,

problem is (was), that every request with http was automatically redirected to https. Which do not works correctly in Locus. And when you set base url to https, all requests on tiles were generated also to http, but redirected to https.

Anyway I changed part that download map tiles (hope it will not be a problem on any different place) and now maps works correctly.

I do not know if this is a problem only in Locus, but these maps are here in middle Europe really slow - but works now ;)

Thank you for a precise report!


Hi Menion !

Woooow ! Great !

I guess the fact that these maps are slow is probably more a country (not yours) www network outflow problem.

So, let's wait your next Locus version now ! :-)

One more time ... many many thanks to you and your team Menion !

Best regards.


Better thanks after you will be sure, it works ok ;)


Hi Menion !

WMS links work fine now with your last version 3.0.0. Cool ! Many thanks again !

However, if i tap on :


it displays this message :


Best regards,



uff, this was hard :). Thanks ... fixed


Menion wrote:

uff, this was hard :). Thanks ... fixed

Replies have been locked on this page!