Zoom lock is changing current zoom

Ingo Rau shared this problem 4 years ago
Solved

Hello!


I probably have a different expectation than others (cf. http://help.locusmap.eu/responses/bug_with_locking_the_zoom), but I would expect the Zoom lock button to just lock the current zoom level and not affect the current display.


Usecase:

I have a very detailed Topo map and a high-density screen. Sometimes I want to keep the current detail when zooming out, so I press zoom lock. Now the displayed zoom changes - I can't quite figure out if it's just the "natural resolution" of the current zoom level or another one, but it's very distracting, because I have to manually zoom back to where I was.


Addendum:

In http://help.locusmap.eu/responses/zoom_lock_scale_default_needed it says something about "no need for a setting whether to zoom-in or zoom-out" - that may be correct, but I would really appreciate a setting (config.cfg is ok) to turn off this behaviour completely.

Comments (9)

photo
1

Good day Ingo,


I read your topic twice, and unfortunately I'm not able to understand it correctly.


Zoom-lock lock current zoom level (so for example 12) and allow to only zoom in/out inside this layer. So for example zoom in from 12/100% do not skip to 13/100%, but to 12/200%. Same with zoom out.

photo
1

Hello menion,

thanx for the incredibly quick reply :)


I understand the basic concept of zoom lock, that's exactly what I want. Perhaps my problem is better explained in a shorter version:

When I press Zoom lock, the current map display changes.

I would expect it to work as a switch, e.g. the zoom level doesn't change anymore when I zoom in/out with fingers - but I don't want my current display to be affected.


Also, when I repeatedly press zoom lock, it switches between two zoom levels - why? Lock should just prevent zoom level changes from happening.


I understand that this automatic may be useful to some - for me, it's very distracting.


Hope that's more understandable - thanx for taking your time...

photo
1

Even shorter:

I would prefer that the Zoom lock only affects zooming operations from now on, not doing anything the moment it is pressed.

photo
1

Ah maybe I understand.


It works in this sequence


- zoom level: 11

- zoom in - level change to 12/100%

- zoom lock - level stay at 12/100%

- zoom in, zoom in - level change to 12/400%

- disable zoom lock - level return to 12/100%

- enable zoom lock - level set to 12/400%


So Locus remember last set zoom lock value and return to this value when you use zoom lock again. Anyway if you want disable this behaviour and always remain at X/100%, this is currently not possible.


EDIT later:

I understand that this may be useful and maybe for someone even a more logical, so in next version will be "map_zoom_lock_remember_last_state" parameter in config.cfg file so you should change this behavior.


More about config.cfg - http://docs.locusmap.eu/doku.php?id=manual:customization:configuration_file

photo
1

Hello again!

I fear we still have a misunderstanding here - although that setting you want to include is definitely also a good thing.


But I don't want to lock at X/100%, I still want to be able to change the zoom percentage, just not have anything happening the moment you press "zoom lock".


I'll give you a sequence how it is now:

- Zoom level: 11

- Zoom in to 11/150%

- enable tzoom lock -> zoom jumps to, say, 11/100%

If "zoom lock" was just a switch, nothing would happen the moment it is pressed, in this case the zoom would stay at 11/150%. This sudden change of zoom is what's a little annoying to me. Just when I had the perfect zoom level and the right "size" of everything, I lock the zoom and it all goes back to some default.

photo
1

Understand, thanks. Then anyway explain to me, why you even use this zoom lock? It still allows to use zoom in/out keys, pinch zoom etc.

photo
1

Perhaps it's specific to the map.

It's the very detailed SwissTopo map (bitmap), where some zoom layers are quite different in amount of detail. So when I zoom out, a lot of detail gets lots - which wouldn't be necessary, as my tab is super-HD, so I could still have all detail, but just smaller. So I lock the zoom and zoom out. But now, the zoom lock first changes the current display, which is distracting, especially when the zoom level changes. This will probably be fixed by your new setting, thank you for that. If in that case you could also leave the zoom percentage unchanged, that would be perfect.

Thank you again!

photo
1

Hi there!

Just tried out 3.5 - works great. I had some difficulty explaining my problem, but in the end you implemented what I wanted. :)

Thx and keep on the great work!

photo
1

Fine, glad to help :)

photo