Auto-backup running & indication needed

Andrew Heard shared this problem 7 months ago
Solved

Was running Locus Pro 3.30.0. I have auto-backup disabled because previously when I turned on my phone I sometimes had to tap the Locus icon many times until annoying backup & message were completed. I decided simpler to do my own manual backup at time of my choosing. But even after disabling I still got this larger (improved?) message:

899228ae8d38068f4e616ffd62951588

Suggestion: if backup is running provide user with some progress indication and same CLOSE button but then automatically start Locus once the backup is complete.

Comments (7)

photo
1

Maybe there is some conflict between Locus Pro and Locus beta. Even though auto-backup was disabled in Pro it was still (by mistake) still enabled in beta. The screen capture in my first post is probably from Locus beta and I mistaken it as Locus Pro screen. See further suggestion here.

photo
2

Hello Andrew,

hmm this is possible (some mess between Pro/Free version), but really unexpected. At least, I never had a problem here as I know ... will test it.

You are correct that this information screen visible right in the moment you wants to use app is weird. Problem? Set automatic backup to night. Anyway, understand it may happen. I firstly made an extra button that allows to minimize dialogue and automatically start Locus after the backup is done. Anyway, then I've realized, that I may keep visible loading progress with clearly visible "backup task in progress". So running backup will be just part of the loading of Locus Map app. You will see in next version ... this sounds to me like an ideal solution. Thanks for pointing on this problem.

photo
1

Thanks Menion.


>Set automatic backup to night.

I am unusual. Phone is normally only on when I want to use Locus. So auto-backup will therefore be first background operation. For now I have disabled auto-backup. Better I do a manual backup as last operation before turning off instead of first operation.


>So running backup will be just part of the loading of Locus Map app.

excellent!

photo
1

Looks like I'm not the only one complaining about an auto backup is running and you don't see this (missing notification).

http://help.locusmap.eu/topic/missing-autobackup-notification-while-backup-is-running

photo
1

Sure, that's why I made some improvements here.

photo
1

Ahh great :) Many thanks. I'm curious about it,.

photo
1

Many, many thanks :) Works great!

photo