Elevation chart not working when following *route*

Guy Evans shared this problem 6 months ago
Solved

I upload a GPX route (not a track) and then guide along it. I click on the "guidance button" and then select "Information" and select the elevation chart. The chart is mostly empty - see the screenshot (similarly the elevation statistics are also completely wrong). This happens if I import the route and choose to override the altitude or not.

If I look at the elevation chart for the route - when not guiding along it - then it displays properly.

Also, if I take the same GPX route and convert to a track with external software prior to importing into Locus, then it works as expected.

Replies (1)

photo
1

Hello,

may you please share with me your GPX file for the test? I would like to use exactly the same source data as you. Thank you!

Jiří M. aka Menion

photo
1

Attached.

photo
1

Hmmm that was exported from Locus Maps. I see it's converted what was originally a GPX route into a track, and added a number of waypoints. Attached is the original GPX route.

photo
1

Hello, thanks for the files. I probably see the problem. It is really related to the fact, you used such track for navigation and Locus Map internally convert track a little bit to generate navigation commands.

I've just today morning updated this behavior so it should be fixed in next version 4.1. let me know later after test if there still be any related problem (should not).

Thanks.

photo
1

Ok thanks! I will let you know.

Related, is there any way to turn off/hide the navigation commands? I tend to just use guidance so they serve no purpose. However, the navigation points are still generated and displayed on the map view - the popup icons can be a distraction (in particular at more complicated path junctions).

(A workaround seems to be to export the route as a GPX track from the route planning software I use but I prefer to keep GPX tracks for my own tracks and GPX routes for routes that I am planning to follow.)

photo
1

Heh funny.

You are probably looking for this 7 years old topic with my few hours old answer right? :)

photo
1

Yes :-) That's perfect. Many thanks.

photo
Leave a Comment
 
Attach a file