Locus Map Pro and Locus Map 4 don't work anymore

Radu shared this problem 46 days ago
Not a Problem

It all started when I downloaded Locus 4, because I was curious about it and wanted to compare it with Locus map pro. I've noticed that my tracks and points were there in the new version. However, the app was not costumized like the other version that I use, so I manually used the restore function and tried the last backup file, thinking that maybe this way the app will look similar with the pro in terms of buttons and appearance. Then I started to see an error and the app crashed. I uninstalled, thinking that I will remain on my main app, Locus Map pro. But after the last update, when I entered the app, a day after I uninstalled Locus 4, I noticed that I have the same error/crash problem with this old version. Here are are a few printscreens. Nothing seems to help: restart, restore or uninstall/install again...

Comments (2)

photo
1

I managed to solve the problem. I've come across a method and I tried it (it was sugessted there). I downloaded a backup file from the google drive and unzipped the data, then I copy/pasted tracks.db and waypoints.db into Locus/data/database folder. After that, the app successfully started. And once I was in the app, I could restore all functionallity with the last backup file.

photo
1

Hello,

Thank you for your report. I'm glad you were able to resolve the issue.

Have a nice day

Andrea