BRouter calculating different routes for equal profiles in LM3 and LM4

Sonny shared this problem 7 months ago
Solved

Hi, I created a short rout in Austria from N47° 31.352/E12° 01.605 to N47° 31.694/E12° 01.413 using BRouter with profile "Bicycle fast".

In LM4 the result seems to be correct, the route is following the serpentines of the track (btw: the same as LoRouter calculates).
In LM3 the result is very diffent, cause it's following the direct, parallel hiking pathes.

Why both results are different, is LM3 maybe using "outdated", older BRouter profiles or an older BRouter-router engine?

Replies (4)

photo
1

Hi Sonny. Which routing profile are you using on both? I just tried on my end and i got the same result on LM3 and 4 (routing over the hiking trail). Both have the "Trekking-fast" profile selected for fast cycling (I think it was selected by default). Maybe you have selected another routing profile on LM3?


I use the same route for my routing tests (are you from the area?). For MTB touring, I ended up modifying a routing profile to strongly penaltize trails, because all profiles I found routed over the hiking trail. My profile now works great for MTB touring in Tyrol. I can share it if you are interested.

photo
1

In LM3: "trekking-fast", in LM4 the default for "Cycling Fast" (i'm not able to see advanced settings like the exact profile setting used in LM4 free version).

I think LM4 profile works correct, since routing along tracks with a bike is perhaps faster than using paths although they are shorter.

I dont need a certain profile, I just would like that identical BRouter hiking, cycling or car profiles are calculating the same routes in LM3 and LM4

photo
1

Settings button to see the used routing profile is also there in LM4.

photo
1

I think the reason is that you are using LMv4.19 and I used LMv4.20 where routing settings-window and perhaps also BRouter routing-algorithms changed. If using LMv4.19 I get the same (less ideal) result as with LMv3.70.3

photo
photo
1

Hi guys,

both results have to be identical!

Sonny, BRouter is fully available even in the free version of LM4. The best is to create your own profile based on, of course, an identical profile file.

If something does not work as expected, screenshot or short video may help, thanks.

photo
1

Ok, I new-installed all apps: BRouter, LM3.70, LM4.19 and used the standard profiles, eg. "Walk" (=BRouter Routing pofile "Walking-SAC1-SHRP) or "Bicycle Fast" (=BRouter Routing profile "Trekking-Fast"). Now they are identical. I think perhaps I've manipulated the default BRouter-profiles in the past... ;-)

So "problem" is solved for now, I'll compare them again with new LM4.20 where Routing functions changed a lot.

Leave a Comment
 
Attach a file