Map stops recording - oneplus phone

mike savad shared this question 2 months ago

i had to replace my phone, i have new oneplus 11 if that matters. they keep updating it. before the updates, i was able to record a full track like i normally do. i tried it today and it cut out about 5min into the trip. i wasn't timing it or looking at it.

i got to where i was and found it didn't record much. i looked to see if the battery manager was cutting it off, and it was naturally, i turned it off, and it seemed to have no issue recording me while walking in a greenhouse.

get back into the car, it records for about 5 min, and then stopped again. i haven't tried it again, i'll try again tomorrow. but i'm not sure where to look. i don't think its locus, i'm nearly certain its the phone, every time they update something else breaks. but maybe someone here knows what that thing is? probably something i'm overlooking. pretty sure i turned on the - stop optimizing everything mode.


Replies (8)


i just checked, its set to allow all the time. i did find something in the program:

disable when app is hidden, and that was set to on. i turned it off, which i assume will keep the gps on? i can only test this if i'm out on a trip again. its weird that it did keep it on for a while when i was walking. or i think it did.


so i ran it today, in an office, not moving much for over an hour and it seems to be working, drive down the road and its ok, then suddenly its not. its like it lost consciousness. the gps should still be on but when i'm in the car it seems to have a countdown timer of like 1-2min and it cuts out. any cause for that?

i reenabled that disable when app is hidden because the gps didn't bother even turning on.

i'm sure i'm overlooking some weird setting they put in there, is there something else to look at? and why would it cut out when i'm driving?


Similar/same problem. I suspect that oneplus is as aggressive as their Huawei others and sisters.

The NMEA logging (if switched on) shows what Locus gets from the operating system (Android).

On the other hand: not sure if Locus can "motivate" the oneplus Android more to deliver.

Does your device have Google Maps installed? If yes, I would run that in the background. Plus Locus in recording mode.

If that does not change the outcome a second test: make Google do some routing to somewhere (switch off the voice ;.)) and make Locus do the track recording.

If that should help, it would not necessarily mean trhat Locus can do more, as GM is more deeply integrated into Android that a normal app can. be. But at least you would have an (ugly) workaround.


PS: on my Huawei tablet they even kills BBS and 3C recording after some time - both have nothing to do with GPS, but are privileged apps recording battery relevant and other system parameters. Until they are terminated by their Android version, regardless of foreground/background etc. settings. Those guys in China simply ignore the settings.


my next test is to leave it on to super mode where it doesn't optimize anything. so far i see no difference in battery drop, hoping this time it will work. i've had so much trouble with this one plus, i miss my old phone but the battery just couldn't keep up any more.

i do have google maps, i suppose i could give that a try also, another tool under my belt anyway. its just weird how it stays on when walking, but off when driving. or driving for a short spell.

i think the phone is far too aggressive when it comes to the battery. and they hide a lot of the battery saving functions.


i reset all the settings on the phone, i think the gps is working - but only when the program is in memory. when i turn the screen off, within 5 min or so, the program itself exists or crashes or is removed from memory.

and i don't know why. when i go back in, its still recording like nothing happened, but its not on the maps when i turn the screen back on.

is there some other setting i'm overlooking? (oneplus made a mess of the settings). i'm hoping for an easy fix, i just don't get what's going on.. i do know, that i wish i never updated the phone.


i'm crossing my fingers this keeps working. i'm putting this in just in case i or someone else runs into it. but i:

turned off all optimizations on the program

allowed locus to never optimize

turned off sleep optimize (not sure if this did anything)

turned on background, (forget where that's located), to keep this program and others like it in the background. may have been in the battery section

then went back into the locus program and unchecked and rechecked to run as a service.

and so far, letting it sit idle, it didn't remove itself from memory, not sure if it will track, i'll try again tomorrow.

Leave a Comment
Attach a file