Geocaching.hu: geocaches are not imported properly

Bálint Szebenyi shared this problem 6 years ago
Solved

Hi!


I use the site geocaching.hu, because I prefer this to gc.com. This site is much better adapted to our country, with more detailed caches. (This is of course a matter of personal opinion :))


The problem is that exporting caches from the site and importing them into locus works, but there are some problems:


1 - some 'regular' caches that have additional point references like: park your car here, take photos here. These are not handled well. Most of the time they are imported but they are made visible separately not as waypoints of a cache. So if the cache is visible all its waypoints are because they are not treated as waypoints of the cache. They are not present as items in the waypoints screen of the cache.

It would be desirable to treat them as waypoints that way the map would be organized much better.

I have attached two logs that work differently for some unknown reason. The 'fine' works as it should, the 'wrong' handles waypoints badly.

So there are some caches that work as intended as the example above shows, but I could not figure it out using the gpx files. I tried to analyze them to see where they go wrong but to no avail.


2 - Multi geocaches: I usually get "point with the same name already exists" message if I import a cache. Thise leads to show only one waypoint of a multi cache: the final one. It would be nice if it could be handled properly and group them together in one cache: I mean the cache would be the first/last of such occurences, and the others that want to overwrite it should go to the waypoints as intended.

I have checked a file and include one for example, the urlname tag could help to see that the file contains seemingly two caches whereas they belong together, hold many common info, but one of them should just be a waypoint.


3 - Waypoint/Coordinate descriptions are included in the long description field of the gpx and they are not formatted nicely. I have attached a screenshot. They could be hidden as they are useless there. Or it would be nice to make them 'clickable'. If clicked they could show that point on the map. (Just like when an address is being searched for locus places a simple icon there)


Note: gpx files are compressed, the site would not accept them as gpx files.

Comments (19)

photo
1

Hello Balint,


I wanted to check at least first points and seems you wasn't succes with adding attachment. May you please try it again? Thanks

photo
1

Sure. For some reason they have not been included although I have attached them.

photo
1

Hi,


thanks for files.


So


1. it was easy. Will be fixed in next version.


2. I really don't understand this. Why one cache has two points in file? Both has same name, but little bit different code? Why it isn't just one point??


3. I also do not understand here. Why are in listing coordinates, when you do not want to see them? Also is there any official syntax that is always used for a block of text that represents coordinates?? Ah still don't get it. If I want any coordinates attached to cache, they should be placed as a separate waypoint.

photo
1

Hi!


Wohooo :))) Great news! Thanks


2 - It is a multicache. Like for example this on gc.com: http://www.geocaching.com/geocache/GCF01A_jalsos-multi-cache It consists of multiple waypoints.

The coordinates are different in the file as I can see.


3 - I believe that those coords are also placed in the long description and also separately at the end as needed. (The owners of the caches reference those points somehow. I do not own a cache yet so I can only see the gpx file downloaded, and I do not know how the editor of the caches on the website looks like) It is enough to show the ones that are placed as separate waypoints, as I believe these are identical.

As I can see the unnecessary parts begin with ">coord lat=..." and end with "<", and these should be removed/converted to links/converted to icons/substituted with the 'description' part that is to be found between the beginning and ending parts for nicer description.

(The attached screenshot illustrates that these parts may span as much as four lines that's why I though that if there is a possibility to tidy them up, then it would be useful.)

photo
1

Hi.


2. yes, but all!! caches downloaded from Geocaching.com are always! one main point and many attached waypoints. In your case there are two main points with same name, but different coordinates. So sorry, but it's really some weird system on Hungarian geoaching site. Anyway you should be able during import choose on question if you want to overwrite, buttom "Ignore". This should import both files.


3. Hmm, sorry, but I still feel little bit weird about it. If author create listing for cachers that contains some information, then why should I hide part of them?


Also this cacher choose > and < as a symbols between which he placed coordinates. But some other owner may use same symbols and place between them some important information. And if I follow this, I hide it also.


So sorry, but I really see no sense in this point.

photo
1

Hi,


2: I have checked the situation and I can confirm I can import all the wpts of the multicaches by choosing ignore, however this really clutters the map.

You have kindly sent me a gc.com gpx file, but I had to find another as it did not have any waypoints due to calculations. My bad, but someone was kind enough to send me one that fit better to compare.


I have attached those - they are the same cache. (Some gc.hu caches might be found on gc.com, they are identical) What I have seen is that:

- gc.com uses two files (that's how they were sent to me via e-mail from gc.com system): one GC18B7H.gpx and one GC18B7H-wpts.gpx. The GC18B7H.gpx contains the first cache and the waypoints are in the GC18B7H-wpts.gpx file. They are referenced by their names: P218B7H, P318B7H, etc.

- gc.hu uses one file: GCPASA.gpx. There are parts that repeat themselves and contain the waypoints. GCPASA-1860-1 is the name of first of those and it is the same as GC18B7H.gpx The GCPASA-1860-2, GCPASA-1860-3, etc. are the waypoints. (Unfortunately the long description is included with every waypoint, that is of course absolutely unnecessary and do not have to be included.)

...............

Full comment is attached. For some reason the part after the '!' mark went missing. :P

photo
1

continue:

Only the coords + name + icon + the contents of the

inner square brackets from this are needed:

<desc><![CDATA[Pasaréti templom]]></desc> ----->

"Pasaréti templom"


So actually the names are different and make

it possible to separate them from one another. Is it this way possible

for Locus to handle this situation?


3: You are right about

checking for > < is not right. Hiding them may also not be a good

idea, you are right. Well, I thought about it and realised, that

actually what disturbes me is the unnecessary technical characters that

are displayed.

So from the source:

"""

2. pont

&gt;coord lat="N 47° 30,906'" lon="E

19° 00,065'" altitude="154"

multi="v" icon="32"

description="Gábor Áron emlémű"&lt; A jelszó

2. része az emlékmű készítő vezetéknevének első betűje.

"""

This should be made:

"""

2. pont "N 47° 30,906' E 19° 00,065' 154m Gábor Áron emlékmű" A jelszó 2. része az emlékmű készítő vezetéknevének első betűje.

"""

I guess "&gt;coord lat="" and ""&lt;" together should be safe to find these parts.

The website also displays it similarily: http://geocaching.hu/caches.geo?id=1874

photo
1

Hi,


I'm checking once more your multicache (file gcemh_multicache.gpx) and I have to say sorry, but I won't do it - I mean support for this. For a few reasons:


1. I absolutely do not understand why geocaching.hu do not keep defacto standard in GPX files defined by Garmin & Groundspeak.


2. Both waypoints in file has different ID and I do not see key, that say on 100% that one is cache and second is waypoint to previous cache.


3. Second waypoint contain full specification of cache as well as first point. Locus automatically recognize such points and fully valid geoaches as is common in Groundspeak GPX files


Isn't there any settings on geocaching.hu pages, where you may choose which format of GPX you get?

photo
1

Hello,


sorry I did not have the time to write.


Regarding

point 1: it works now :)) and it is much better this way! One minor

thing: icons are sometimes missing. See attached gpx file. Is it

intentional? Or should it be the default "blue eye"?


Point 2-3: I

also do not understand if there is a standard why they do not adhere to

it. I don't think that the site has too active developers so I will

have to accept it. There are other file formats as well but they do not

look good as far as I can judge (gdb, loc, txt, csv, wpt, gtm, ov2, pdb,

csv, vcf). The one I choose is gpx (geocaching) - this is the way it

stands there.


I understand you cannot support non-standard

things, there are other things to spend your time on. Nevertheless I had

to ask and thanks for taking a look. I will write a converter for point

2-3 once I have the time. :)


ui: gpx files should be allowed to upload here ;)

photo
1

I!m checking your file. There is a problem, that all waypoints with missing icon has defined icon as


<sym>Dot</sym>


and Locus do not know 'Dot' symbol. So when you will write own converter, I also suggest to replace 'Dot' for any of supported Locus or Garmin icon names. Or even better - to any of globally used waypoint types defined by Groundspeak. More about it here http://support.groundspeak.com/index.php?pg=kb.page&id=72

photo
1

I think I have done it. I have tested it with:


single cache

single cache with preceeding waypoints

multi cache

multi cache with preceeding waypoints

one whole area downloaded


The source file is an incredible mess that I download from the website. Honestly how could the developer left it in that state, if this is the most used one?! It was a real PITA to sort it out.


Once I have tested it (and cleaned up my code from comments, not used parts) I will release it for everyone with sources of course.

photo
1

I have run into a bug but I cannot debug it. Locus says there is a problem with this file. I have sent you a bugreport about it, when it crashed. It has happened around waypoint 118-119.

photo
2

Hi, I'll gladly help


In you file is issue on line 26232

  1. <groundspeak:name>Vörös & Kék</groundspeak:name>

XML files cannot contain & character directly in text, as you probably know. There have to be CDATA in content of 'name' tag or this char has to be escaped.

photo
1

Ahh! I thought it would be something like that, as around thousand other caches have been imported properly, just didn't know where to look and what to search for. I didn't know about '&' being an illegal char, but I will fix this. Thanks for your help!

photo
1

suggest to read for example on this question: http://stackoverflow.com/questions/730133/invalid-characters-in-xml , it should help

photo
1

Fixed it, forgot to call a funtcion when processing that tag, what I did for the others. Now it works flawlessly :)

photo
1

Perfect.


It's really weird that this 'hu' site generates so untypical GPX files. Are these files used also in other applications and has only Locus problems with it? Hmm anyway good you found a solution to make it work. Congrat :)

photo
1

It is really incredible that it generates such a mess. Unfortunately no developers are active there as far as I know, because it should be fixed at the source, not by a separate script.

I only use Locus so I do not really know if handheld units like garmins are affected or not. Maybe they use the gdb export option that is specially for those units.


I will advertise this little script for the people on the forum there as it might be useful for others as well. By the way if someone stops by here: sources are available at: https://github.com/szebenyib/gpxconverter

photo
1

Perfect, understand.