Locus Map Pro + Add new route = keeps stopping on SGS S8+ A7

Mike Mmm shared this problem 2 years ago
Solved

Just bough Locus Map Pro and add new route doesn't work.

I am trying to create route in mountains and as soon I click it will show information that app keeps stopping.


In a city it seems to be working.

I am using GeoCaching addon.

Doesn't matter which map I am using (tried several).

Comments (6)

photo
1

Hi Mike,

what service do you use for navigation?

MapQuest, GraphHooper, Yours, OSRM or BRouter?


This problem is probably with the provider.

Optionally, there are no navigation data in this area.

photo
1

Any of those.


I have tried MapQuest, BRouter, Yours.

I think it has something to do with calculating route. One of advanced profiles (hiking mountains) had a missing file and wasn't calculating, but did add the waypoints. Any other was simply crashing.

As soon as I try to calculate route it will stop working (Scotland). (it looks like the bug is activating when I try to click on the map near the top. When try to calculate route from my position it works fine).


Edit

Nope, it doesn't even without calculating the route is still stops working.


The navigation data is there, the provider doesn't matter. Map also doesn't. It looks like an issue Locus Map, as I've tried different maps/providers/navigation techniques (manual/auto)

photo
1

I do not know...

I try hiking and a car...

Everything is working for me in Scotland.

For example via GraphIHopper.


+ edit

Mike,

You must describe in detail what does not work. Or to give a screenshot.

Then the author will be able to advise or correct the error.

photo
1

Hi Mike,

as Condor has written here - we need definitely more information. Please describe what you do step-by-step, what version of Locus do you have, what routing service you use. We have to simulate the problem, then we are able to solve it.

best regards

Michal

photo
1

I just bought it so the newest.


Any map, any routing service.

I am using only addon for geocaching.

Turn on => Add new route & measure => Computer route (walk) (any routing service) => click few times and get Locus Map has stopped (it start crashing after I selected geocache location as a part of a route).


I can add few waypoints but as soon I select any geocache location it will crash instantly.

Navigating to geocache location seems all right.


I am using Geocaching4Locus (newest as everything installed Today).


It happens only when I tap a geocache location. If I will use the interface to add new point for route it seems to be working.


Just tried on another device (galaxy tab s2.0 9.7 2017 Android 7.0)

Installed Locus Map Pro

Geocaching4Locus

Downloaded some list

When routing to a geocach location app close itself and after re-open the geocache locations are missing (had the same issue on the galaxy s8+ but simply downloaded locations, closed app and after crash the locations were there, so not sure if locations are saved in cache and then to SQL database or what is happening).


So steps to recreate bug on Samsung device with Android 7.0:

- Download new Locus Map Pro

- Download Geocaching4Locus

- Download list (I have tried 300 items list, all settings default)

- Create new route

- Start creating route and tap on any geocache location

It will crash. Doesn't matter map (still Scotland but even Garmin img map has the same issue when loaded) / routing service.

photo
2

Hi Mike,

thanks a lot for the detailed description - now we know where the bug is and we are able to simulate it. Unfortunately, the author of the app is on vacation so the fixed version will go out later.

Michal

photo
1

You're welcome.

I actually took your app for a spin and compared it against Garmin Oregon in geocaching.

And I really loved it, really nice app, everything is stable (beside the above bug) and I prefer it over the Garmin Oregon (it seems that SGS 8+ has better reception in heavy woods than Oregon).

Good job !

photo
1

Hi Mike,

the issue has been fixed as can be verified in the latest Beta version 3.25.5.2.

photo