LocusPro lost connection to GPS

Bogdan Kot shared this question 2 years ago


I found similar topic but it didn't solve my problem.

Some day, I dont know when and why, LocusPro stopped to activate GPS device. I found it when I tried to record track but nothing was recorded. I checked settings. In my opinion they are OK. Other applications activate GPS correct and they are working OK. I installed GPS test application an it shows that GPS works correct. When I turn on applications using GPS i see GPS icon on android status bar, except LocusPro, because LocusPro doesn't activate this icon and GPS. I tried to switch GPS on/off many times inside application, but it didn't help.

I tried to ..

1. Reset LocusPro to factory settings - no change

2. Reinstall LocusPro - no change.

Edit: I tried also to reboot device and to give root access to LocusPro - no change.

I attached screenshots, you will see settings.

Do you need any other screenshots ?

What to check more ?

Thanks in advance


Comments (3)


Hi Bogdan,

- check settings >GPS&location > Run at startup

- check GPS icon indicator - is it white/orange/green?

- check your system Google Play Services - do they have location access permission?


Thank you very much for your support.

It was third problem. Google Play Services had disabled access to location services.

I didn't know that there are such dependencies. Thank you very much for your help.




Hi Bogdan,

since version 3.30 Locus uses a new system of acquiring location - fused location provider by Google. It combines all device sensors in a mix of battery efficient output. Sometimes, unfortunately, Google services don't have location permission by default.