Navigation speech (TTS) stopped working

Viajero Perdido shared this problem 2 months ago
Solved

Hi. I'm going nuts trying to debug the sudden loss of spoken directions while navigating. This used to work, suddenly it doesn't.

Tap a point, navigate, car/walk/whatever, navigation starts. No "Let's GO!". No "after 200 metres, turn right". It navigates properly on the screen, but totally silent.

Tried Google TTS, tried Ivona (my favourite). No difference. Tried BRouter (both profile settings) and GraphHopper, no difference.

Made sure "Mute" isn't ticked. Made sure all volumes turned up to max. Tried music and notification channel, no difference. Turned off do-not-disturb and made sure Locus was set for priority notifications to override do-not-disturb. No difference.

Voice works in system settings (under Accessibility) when you tap to hear a sample. Tried both default language and English (US), no difference.

In the "out of route" notification settings, beep->play makes a beep, but TTS->play does nothing.

This is on my daily-use phone, Blackview BV6000s with Android 6, Locus Pro 3.39.2. This is also on my old Nexus 5, Android 6, freshly reinstalled Locus Pro 3.39.2, No difference.

In my fiddling with different versions (I also tried the beta on the Nexus, also the older 3.32(?) Pro on the Nexus, briefly it worked properly, then stopped working again. I don't remember exactly which version, but I was tinkering with language settings at the time. So it seems sporadic.

Any ideas? Has anybody else reported this? This was a challenge on a recent trip: we're not supposed to look at the phone while driving.

Comments (2)

photo
1

I figured it out.

I didn't realize there's a TTS language setting inside Locus, in addition to the system's language setting for TTS. (Seems odd, but okay...)

Inside Locus, under Language / Text-to-speech, Ivona was selected (as I'd expect), but with Danish as the language. Danish?!? It showed Danish on both my daily-use phone, and also on the freshly-installed Locus on the old Nexus. I'd never have selected Danish on purpose, but maybe accidentally by "pocket dialling". But not on two devices....

I just had to select English, and it all worked. But what a journey.

photo
1

Hi,

Locus Map has its own TTS settings because many users use multiple TTS engines in their phones and they may select which one works best in Locus.

Your accidental setting of Danish is quite incomprehensible for us and, of course, we can't simulate it.


Best regards

Michal, Locus team