This object is in archive! 

Round trips and navigation

Benjamin Brücker shared this problem 4 years ago

When navigating I have a problem with round trips.

At OsmAnd this is not a problem. From the beginning the course is calculated from the start to the end point. Unfortunately not with Locus. So shortly after the start I'm told that I'm only 2 meters away from the finish. Only after I have driven or run several kilometres do I get a realistic indication of the distance to the finish.

I use tracks I have planned with Locus for the navigation.

Is there any way to improve this?

Replies (4)


Yes, I had observed this kind of response when navigating pre-planned round trips. Especially when first and the last part of track are the same or very close one another.Then when i start navigating, track and distance is corectly displayed, but after a short time, recalculating start to take place and the track is modified(directly to the finish point) so no good

This is the present logic of routing of Locus ?


Good day guys,

not sure if Benjamin has same problem as Marius.

Benjamin, how you start navigation? Directly by a tap on the map on the route and from popup menu choose "Navigation"? App most probably starts navigation along the route from the point you selected. It may be the final destination, which may cause this problem. In case, such similar issue happens, it may be useful "Nearest point" option in the main navigation menu.

In the second case, isn't this expected behavior if you have enabled recalculation (to the point)? You just say the app that if you leave route, you want to recalculate to next valid target point which is the target. So simple solution > disable recalculation.

How behave OsmAnd? Is there option to turn on/off recalculation? And if so, it does not recalculate to the final point if you left route?


Hi Menion,

sorry that it took so long time for a replay.

First think I observed using OsmAnd is, that this App does not seem to do any kind of routing, if I choose a track to "follow". It simply calculates the time. If I start navigation, it OsmAnd asks, if it should use the displayed track. It does not make any difference, if the first or the last point share the same coordinates.


What happens on OsmAnd if I move a way from the track by certain distance, ist that OsmAnd tells me a route back to the track I have chosen for my trip. That's quite simple. I prefer Locus, because of bugs in OsmAnd the developers cannot or are not willing to solve (slow rendering at Android 8). So I switched to Locus, and I found there features, which I miss on OsmAnd. But to be honest, Locus has a more strict learning curve. But which software with so many features doesn't?

Ok, Menion, this is how I do the navigation. I chose the navigation command from the trip PopUp menu.


I marked my position and point somewhere in the middle of the route. As you can see in the below part of the screen, I'm near the starting position. You can also see there are green arrows in the track. I would expect, the navigation would follow the track. For what other reason should I choose navigation from a track?

The calculated result is not fitting:


As you can see, Locus want's me to turn just back. What is confusing, because there are black arrows for a different direction. I tried several things with the same result:

  • I tried "Navigation" and "Zielfürhung"/"Guidiance".
  • I did chose points at first quart, half, third quarter at the route, and clicked then in the Pop-Up menu to launch the navigation.
  • I clicked on different points. I also used an extremely large scale to point near the last point I had edited for the track.

I'm sure there is an Option I did not find to that trip. BTW, is there a way how to export my settings? I would upload that file, and you could check, if there are some configuration settings not fitting to that what I want to archive. I'ts not very convenient to work with screenshots.

Maybe a step-by-step how-to for round trips could help. I will do some hiking in Czech Republic an Mallorca during next week and I really do miss the option.

THX for your patience reading this.


Hello Benjamin,

I believe this is a similar problem that not just you suffer. I've improved dialog that starts navigation and it will be published in today/tomorrow new version so please give it a try. The main difference is that it will by default work as you expect.

What happens now, is that Locus Map use to point you tapped on, as the starting point for navigation, which is a problem here.

Replies have been locked on this page!