Vector Maps add-on

joerg.napp shared this question 8 years ago
Answered

What happened to the Vector Maps add on?

Comments (9)

photo
0

Hi,


it is no longer available. From the beginning it was only valid untill 29.02.2012. Now it isn`t available anymore. For getting Vector Maps you have to see into the Locus Shop (call it from the list of functions).


Cheers

photo
0

Yes, I see the vector addon has been removed from the Android Market. It was am interim solution, to get the vector maps started. I got my money`s worth out of it.


Out of curiosity, about two hours ago, I downloaded a small vector map (Washington DC) through the Map Manager as usual. It downloaded, unzipped, and displayed correctly.


In the interest of fairness, I then uninstalled the vector addon, then entered the Locus Shop and purchased 30GB credits for vector map.


Received receit from Market through Gmail. Since in-app purchases have no return period, it should have taken effect immediately, but I gave it some time.


I then went back into Map Maager>Vector Tab>Dowmload Button> Americas>United States>XXXXXX. No joy. I get error msg-


"Unexpected Http Status Code 500"


So then I thought maybe map downloads had to take place within the Locus Shop>Maps Tab> Vector Maps> 30gb>List


The list is a loooong scroll, not hierarchical like in the Map Manager.


For each map, their is a field: "(transfer / SD card)", but it is not active.


Still no joy after two hours.


I am located in USA. Could this be a problem with Amazon server?


When working correctly, which is the valid download method?


If the correct method is through the Shop, shouldn`t the download button on the Map Manager Vector tab be removed?


Regards,


Starman

photo
0

Hello Starman, sorry for these troubles ...


1. Thanks for purchase, anyway users that have add-on, have it valid to the end of June, so save your 30GB on later and use add-on ;)


2. you jumped from one app to second ... did you meanwhile closed locus with confirmation dialog? If no, close it, then open, check if you have 30GB bought in shop and then as usually try to download data in Vector maps tab. There was probably problem because of used and then un-instaled add-on


3. list of maps in shop is just for quick information for buyers. Because when you have nothing purchased, you cannot simple see list of maps. So this should help to imagine what you`ll be able to download ...

photo
0

Hi Menion-


Yes, I did close Locus program before uninstalling vector addon.


In the shop, it does say that I own 30GB.


I considered rebooting phone, but I was reluctant to do so because my screen capture program resides in memory. After rebooting phone, I have to connect phone to laptop and reactivate screen capture program.


But I will now anyway reboot phone.


This issue is not urgent. It is late in CZ. Get some sleep Menion!

photo
0

hmm I see some errors on server when someone tried to download "district_of_columbia.zip" and "delaware.zip" files .. both many times and both always with error. Is that you or some other person have some download issue?


I`m testing them and for me it works correctly.


Hope that reboot helps but it`s weird. Closing (waiting few secs) and opening Locus should be enough in this case!


Yes it`s just midnight. Wife is already sleeping and I wake up at five to work on Locus. So good night :)

photo
0

Good Morning Menion-


Yes, the files you mention were me. I chose them as test files for their small size (~5MB).


After reboot of my phone, all works fine now!


I did learn something however about how map downloading works in the Locus Shop! I downloaded that DC map as a test. Then I closed the Map Manager to test the map to see if it was without error. When I returned to the Map Manager, the rest of my 29+ GB of credits were gone! Evidently you have to download all of your credits in one session. I had assumed that the server would be smart enough to track my usage, and that I could spread my usage over time. Not so! Perhaps some sort of warning should be displayed for dummies like me :-)


Anyway, don`t worry about it. I don` sweat the small stuff, and your app is grossly underpriced to start with.


Anyway, next question- I would like to have the entire United States available in vector, leaving only a few states on my phone, having the rest on my laptop, available for quick transfer if needed. Where I live, I do not have access to cable, and my DSL is fairly slow, so downloading the entire US would be agonizing. Would you consider making map sets available on DVD? The US, at under 5GB zipped should just fit.But i`m guessing that since you are already busier than a one-armed paperhanger, that mailorder is out of the question.

photo
0

starman, what happen to you? How gone? In shop you see 0GB at "Vector maps" items and you cannot download more maps?? I see on server that you download 7MB, so you should have still (30GB - 7MB) to download ... ah damn


have to really go sleep, we should discuss some other download mechanism for you in next days.

photo
0

Menion-


After rebooting my phone, I was able to download one map, the counter in Shop would go blank, and when returning to the Map Manager, I would get the info page saying i had to purchase more credits.


I remembered that I had both Locus Free AND Locus Pro installed, only so that I could comment for both on Android Market.


I uninstalled Free, rebooted phone. Since then, NO PROBLEMS. The counter of remaining GB in Shop remains displayed and accurate, and I have downloaded several more maps without issue.


At least on my phone the problem appears to be a conflict when both Locus versions are installed. So I will leave Free uninstalled.


All is now well in Locusland.


Starman

photo
0

Joerg,


sorry we went little bit offtopic. Correct answer was already from Matthias. Add-on was for whole time only to fill time between in-app billing will be done. Since now, add-on is not needed, so it was removed and replaced by direct purchase of "bandwidth" in application.


As you can see in topic, there are some issues but just for your and startman info. All information are stored on server and not just in application, so when you purchase something, you cannot lost it (till my server will be working :) ).


And to Starman. I`m sure it cannot be problem of both versions installed. Really. It had to be some temp problem. I`ll look at it but have no direct clue where to search and also no one complain yet. Also in your case I suggest to use add-on, really. It`s correct way because you paid for them and is still valid!